Bug 53263 - xorg-server-1.12.99.904 - using space + click in gimp-2.8.0 causes segmentation fault in ActivateKeyboardGrab
Summary: xorg-server-1.12.99.904 - using space + click in gimp-2.8.0 causes segmentati...
Status: RESOLVED DUPLICATE of bug 54934
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Input/Core (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: have-backtrace
Depends on:
Blocks: xserver-1.13
  Show dependency treegraph
 
Reported: 2012-08-08 17:56 UTC by Ole Langbehn
Modified: 2012-09-27 06:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ole Langbehn 2012-08-08 17:56:51 UTC
xorg-server-1.12.99.904 segfaults when I press the spacebar in order to move around an image via mouse.

This bug does only occur when the following line is in my .xsession:

xinput set-int-prop "TPPS/2 IBM TrackPoint" "Device Enabled" 8 0

which disables the ibm trackpoint on the keyboard.



Backtrace:

#0  0x000000000044bbea in ActivateKeyboardGrab (keybd=0x1425990, 
    grab=0x14e2720, time=..., passive=0)
    at
/var/tmp/portage/x11-base/xorg-server-1.12.99.904/work/xorg-server-1.12.99.904/dix/events.c:1567
#1  0x0000000000445620 in GrabDevice (client=0x1643bc0, dev=0x1425990, 
    pointer_mode=1, keyboard_mode=1, grabWindow=<optimized out>, 
    ownerEvents=<optimized out>, ctime=33361854, mask=0x7fff6be0d6c0, 
    grabtype=1, curs=0, confineToWin=0, status=0x7fff6be0d6a8 "")
    at
/var/tmp/portage/x11-base/xorg-server-1.12.99.904/work/xorg-server-1.12.99.904/dix/events.c:5052
#2  0x0000000000529958 in ProcXGrabDevice (client=0x1643bc0)
    at
/var/tmp/portage/x11-base/xorg-server-1.12.99.904/work/xorg-server-1.12.99.904/Xi/grabdev.c:134
#3  0x000000000043b151 in Dispatch ()
    at
/var/tmp/portage/x11-base/xorg-server-1.12.99.904/work/xorg-server-1.12.99.904/dix/dispatch.c:428
#4  0x0000000000429c3a in main (argc=6, argv=<optimized out>, 
    envp=<optimized out>)
    at
/var/tmp/portage/x11-base/xorg-server-1.12.99.904/work/xorg-server-1.12.99.904/dix/main.c:295
Comment 1 Ole Langbehn 2012-08-08 17:57:52 UTC
Initially reported at https://bugs.gentoo.org/show_bug.cgi?id=430070
Comment 2 Ole Langbehn 2012-08-08 19:50:49 UTC
added a bug from ubuntu with a stacktrace that's very similar which is marked as fixed.
Comment 3 Peter Hutterer 2012-09-27 06:14:03 UTC

*** This bug has been marked as a duplicate of bug 54934 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.