Bug 53348 - [855gm] GPU hang whilst playing Imperialism 2 under wine
Summary: [855gm] GPU hang whilst playing Imperialism 2 under wine
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i830 (show other bugs)
Version: 8.0
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-10 17:17 UTC by Bruno
Modified: 2015-03-25 14:13 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
i915_error_state (104.57 KB, application/gzip)
2012-08-10 17:17 UTC, Bruno
Details
i915_error_state with linux 3.5.1 (103.90 KB, application/gzip)
2012-08-10 18:39 UTC, Bruno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno 2012-08-10 17:17:16 UTC
Created attachment 65394 [details]
i915_error_state

Starting a game (Imperialism 2) under Wine ends quickly with:
   intel_do_flush_locked failed: Input/output error


Current system state:
 GPU:     i855 GPU  00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582]()
 Kernel:  3.4.4
 xf86-video-intel: 2.20.0
 libdrm:  2.4.37
 mesa:    8.0.3

Kernel log around error:
[ 3533.660038] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 3533.660056] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
[ 3533.664241] [drm:i915_reset] *ERROR* Failed to reset chip.

i915_error_state attached (gzipped)
Comment 1 Bruno 2012-08-10 18:39:27 UTC
Created attachment 65396 [details]
i915_error_state with linux 3.5.1
Comment 2 Yunrui Hu 2012-08-18 14:03:11 UTC
I can confirm this.
I suffer from the same problem with the same chip(i855).The terminal output and dmesg show the same thing as Bruno's.
The only difference is the game.I don't know whether I haven't tried Imperialism 2 or other games,but both Warcraft3 and Heroes of Might & Magic3 can cause this problem.
Please let me know if I can help.
Comment 3 Yunrui Hu 2012-08-18 14:08:01 UTC
(In reply to comment #2)
> I can confirm this.
> I suffer from the same problem with the same chip(i855).The terminal output and
> dmesg show the same thing as Bruno's.
> The only difference is the game.I haven't tried
> Imperialism 2 or other games,but both Warcraft3 and Heroes of Might & Magic3
> can cause this problem.
> Please let me know if I can help.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.