Bug 53411 - xserver 1.12.99.904 (1.13.0 RC 4) instantly crashes when starting Firefox / Thunderbird
Summary: xserver 1.12.99.904 (1.13.0 RC 4) instantly crashes when starting Firefox / T...
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-12 15:01 UTC by misc
Modified: 2012-08-19 23:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (29.12 KB, text/plain)
2012-08-12 15:01 UTC, misc
no flags Details
xorg.conf (4.93 KB, text/plain)
2012-08-12 15:02 UTC, misc
no flags Details
dmesg (61.52 KB, text/plain)
2012-08-12 15:03 UTC, misc
no flags Details
evemu-describe event10 (745 bytes, text/plain)
2012-08-16 17:36 UTC, misc
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description misc 2012-08-12 15:01:55 UTC
Created attachment 65469 [details]
Xorg.0.log

Since one of the recent commits the XServer will immediately crash when I try to open either Firefox or Thunderbird (not observed yet with other apps).

It is still possible to open their profile managers before crashing with a chosen profile, though.

The xserver was compiled with debug symbols; alas this did not result in a more meaningful backtrace.

* Arch Linux x64
* xserver 1.12.99.904(-git)
* Firefox Nightly, Thunderbird 15.0b3
* pixman 0.27.2(-git), libdrm 2.4.38, mesa 8.0.4
* nvidia 304.32
Comment 1 misc 2012-08-12 15:02:42 UTC
Created attachment 65470 [details]
xorg.conf
Comment 2 misc 2012-08-12 15:03:37 UTC
Created attachment 65471 [details]
dmesg
Comment 3 misc 2012-08-13 18:47:11 UTC
Same with nvidia 304.37.
Comment 4 Peter Hutterer 2012-08-16 03:46:49 UTC
Please get an evemu description for this device and attach it here.

http://people.freedesktop.org/~whot/evemu/
Comment 5 Peter Hutterer 2012-08-16 03:47:17 UTC
sorry, by "this device" I mean the  ITE8708 CIR transceiver
Comment 6 misc 2012-08-16 17:36:24 UTC
Created attachment 65657 [details]
evemu-describe event10

If that's not the entire description, please write what else I should do.
Comment 7 Peter Hutterer 2012-08-17 01:06:54 UTC
ok, apparently not the input device that causes the issues. Can you reproduce this with nouveau instead of the binary driver?
Comment 8 misc 2012-08-17 19:47:35 UTC
Removing the xorg.conf and using a new Firefox profile didn't fix the crash with the proprietary driver, but no crashes at all with nouveau-git.
Comment 9 Peter Hutterer 2012-08-19 23:24:36 UTC
Sounds like a bug with the binary driver, sorry. Please file it with the appropriate nvidia support channels.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.