Bug 53475 - Error performing housekeeping WD drives (10,000 RPM Drives)
Error performing housekeeping WD drives (10,000 RPM Drives)
Status: RESOLVED DUPLICATE of bug 61998
Product: udisks
Classification: Unclassified
Component: general
unspecified
x86-64 (AMD64) Linux (All)
: medium trivial
Assigned To: David Zeuthen (not reading bugmail)
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:21 UTC by Thom
Modified: 2014-06-16 21:11 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
udisks dump (52.26 KB, application/octet-stream)
2012-08-14 05:21 UTC, Thom
Details
udisks --dump (52.26 KB, text/plain)
2012-08-14 05:31 UTC, Thom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thom 2012-08-14 05:21:04 UTC
Created attachment 65526 [details]
udisks dump

My first bug report, hopefully this belongs here.

udisks 1.98.0

I have 4 hard drives, they all function fine.
Three drives are WD Raptors, 1 hosts windows and the remaining 2 are raid0 also ntfs.  I can mount / read from linux and boot windows and all is ok.

My bug is just annoying.  Every 10 minutes I get 3 entries in /var/log/messages to the effect of:
Aug 14 00:47:43 tux udisksd[12940]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/WDC_WD740ADFD_00NLR1_WD_WMANS1173114: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Aug 14 00:47:43 tux udisksd[12940]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/WDC_WD740GD_00FLC0_WD_WMAKE2053058: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Aug 14 00:47:43 tux udisksd[12940]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/WDC_WD740GD_00FLC0_WD_WMAKE2395043: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)

This behavior doesn't change regardless of the drives being mounted or no.

The fourth drive, which is my linux drive, is also a WD but is a standard 7200RPM drive.  The only results I've found online for these errors appear to also be 10,000RPM drives.

I could not ascertain a method to stop this housekeeping from man udisks(1), udisks(7) nor udisks-daemon(8) or if possible, if it would be advisable.  I'll just filter these logs elsewhere for the time being.

I'm attaching 'udisks --dump'

My apologies if this doesn't belong here and thanks for your time!
Comment 1 Thom 2012-08-14 05:31:28 UTC
Created attachment 65528 [details]
udisks --dump
Comment 2 RaptorBug 2012-08-24 07:50:44 UTC
Arch Linux
x86_64
i686
udisks(2) v1.94.0
---------------------

I can confirm the bug with a Western Digital Raptor 10000 RPM disk (the 'udisks' version I am using is earlier than the one reported by the original author of this bug report). I have two other WD disks (7800 RPM) in the same machine and the error does not occur when probing those.

I can manually run (without the '--no-debug' argument):

> /usr/lib/udisks2/udisksd

and the output clearly shows the housekeeping failure for the Raptor while the others succeed.

It seems to me the bug is more likely in 'libatasmart' (which 'udisks' is dependent on) as the 'Input/output error' appears in the output of:

> skdump --overall /dev/sda

As far as a potential workaround (or likely, in my case, a permanent solution), set the following variables in a proper rule in a '/etc/udev/rules.d/' rules-file for any device you don't want probed for SMART data by 'udisksd':

ENV{ID_ATA_FEATURE_SET_SMART}="0"
ENV{ID_ATA_FEATURE_SET_SMART_ENABLED}="0"

For SMART-capable drives, these will normally be set to '1'. Use:

> udevadm info --query=all –path=/sys/block/sda

to see the variables for a particular drive (change 'sda' to whichever device you desire). Piping to 'grep' or 'less' is useful as the output from that command is quite long.

Before setting those variables, I initially tried setting:

ENV{UDISKS_DISABLE_POLLING}="1"

The setting had been a successful workaround for preventing 'udisks' from waking certain devices. I erroneously believed that the setting would prevent any attempts at communication between 'udisks' and the specified device (including SMART probing), but that did not work. I also want to mention that it is likely that setting only one or the other of the SMART variables will do the trick based on a very cursory review of the 'udisks' source code, but rather than waste more time on determining exactly what the code does with its if-then logic (which tests for both values), I just set them both FALSE to be sure.

By the way, the reason I say for me it's a 'permanent solution' (rather than a workaround) is that prior to discovering the error messages in my daemons.log, I didn't even know 'udisksd' was probing my disks every 10 minutes for SMART data while I already had cron-jobs doing essentially the same thing (but at much less frequent intervals) using 'smartctl' from the 'smartmontools' package.

Finally, setting the above Udev SMART-related variables does not prevent smartmontool utilities from successfully running as they are not aware of those variables (the utilities will get the smart-capabilities settings directly from the device, which remain unchanged by the actions described here).
Comment 3 RaptorBug 2012-08-27 16:11:21 UTC
Edit:

The command in Comment 2:

udevadm info --query=all –path=/sys/block/sda

should be:

udevadm info --query=all -–path=/sys/block/sda

For some reason the copy / paste operation replaced '--' (two ASCII code 45 characters) with '–' (one ASCII character code 8211). My keyboard can't even produce the 8211. Shrug.

Apologies.
Comment 4 Peter Hercek 2012-09-05 08:01:21 UTC
I have this problem with my Raptor (WD1500ADFD).

I use smartmontools. ENV{ID_ATA_FEATURE_SET_SMART_ENABLED}="0" was enough to get rid of the error message. I did not try whether the other option is enough too. RaptorBug, thanks for the tip.
Comment 5 vkrevs 2012-10-02 13:09:44 UTC
Same issue on openSUSE 12.2 and a 7200 RPM WD250Gb drive.

Oct  2 11:29:26 stal-dev-lx1 udisksd[17555]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/WDC_WD2500JD_75HBC0_WD_WCAL74728599: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)
Comment 6 John Yost 2012-10-15 12:46:54 UTC
Just a me too report
but:
The error report on my system is for a usb connected external drive, which may help in the debugging. I have attached a udisks --dump file as details.txt

"udisksd[4617]: Error performing housekeeping for drive /org/freedesktop/UDisks2/drives/WDC_WD2500BB_14RDA0_WD_WCANKF372097: Error updating SMART data: sk_disk_smart_status: Input/output error (udisks-error-quark, 0)"
Comment 7 alister.hood 2013-11-17 01:03:39 UTC
Does this relate to #61998?
I saw on a downstream report that the patch for it fixed this.
Comment 8 Orion Poplawski 2014-06-16 21:11:45 UTC
Yes, that patch seems to fix this.

*** This bug has been marked as a duplicate of bug 61998 ***