Bug 53688 - [glamor] some graphic corruption and warning in Xorg.log
Summary: [glamor] some graphic corruption and warning in Xorg.log
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/glamor (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: hejunyan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-18 21:20 UTC by Laurent carlier
Modified: 2018-12-13 18:24 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot (41.65 KB, image/png)
2012-09-18 17:25 UTC, Francesco Marella
no flags Details
xorg-log (37.98 KB, text/plain)
2012-09-18 17:29 UTC, Francesco Marella
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent carlier 2012-08-18 21:20:21 UTC
* Video card is a radeon HD6870
* xf86-video-ati from git
* mesa from git
* glamor-0.5

glxinfo:
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD BARTS
OpenGL version string: 2.1 Mesa 8.1-devel (git-0d308ef)
OpenGL shading language version string: 1.30

relevant Xorg.0.log lines:
[  3485.289] (II) fail to get matched format for 9 
[  3485.354] (II) fail to get matched format for 9 
[  3485.439] (II) fail to get matched format for 9 
[  3485.531] (II) fail to get matched format for 9 
[  3485.618] (II) fail to get matched format for 9 
[  3485.701] (II) fail to get matched format for 9 
[  3485.763] (II) fail to get matched format for 9 
[  3485.828] (II) fail to get matched format for 9 
[  3485.912] (II) fail to get matched format for 9 
[  3485.983] (II) fail to get matched format for 9 
[  3486.045] (II) fail to get matched format for 9 
[  3486.105] (II) fail to get matched format for 9 
[  3486.148] (II) fail to get matched format for 9 
[  3486.194] (II) fail to get matched format for 9 
[  3486.237] (II) fail to get matched format for 210005 
[  3486.280] (II) fail to get matched format for 210005 
[  3486.324] (II) fail to get matched format for 210005 
[  3486.367] (II) fail to get matched format for 210005 
[  3486.414] (II) fail to get matched format for 210005 
[  3486.462] (II) fail to get matched format for 210005 
[  3486.515] (II) fail to get matched format for 210005 
[  3486.559] (II) fail to get matched format for 210005 
[  3486.613] (II) fail to get matched format for 210005 
[  3486.658] (II) fail to get matched format for 210005 
[  3486.721] (II) fail to get matched format for 210005 
[  3486.769] (II) fail to get matched format for 210005 
[  3486.831] (II) fail to get matched format for 210005 
[  3486.881] (II) fail to get matched format for 210005
Comment 1 Francesco Marella 2012-09-18 17:25:28 UTC
Created attachment 67343 [details]
screenshot

I see graphic corruption in GNOME game tetravex. See attached screenshot.
Comment 2 Francesco Marella 2012-09-18 17:29:38 UTC
Created attachment 67344 [details]
xorg-log
Comment 3 Siganderson 2012-09-18 18:42:33 UTC
I have the same problem with the newest git versions (drm, mesa, glamor, xf86-video-ati, libtxc_dxtn) and fedora 17.
I noticed that corruptions are random and in gray places (window's menubar in gnome).
Comment 4 Michel Dänzer 2012-09-19 12:11:44 UTC
Reassigning to glamor for now: The numbers in the log messages don't seem to make sense for picture formats.

Also, AFAICT glamor_upload_sub_pixmap_to_texture() incorrectly returns success after these messages, which might explain the corruption.
Comment 5 Zhigang Gong 2012-09-19 15:56:50 UTC
(In reply to comment #1)
> Created attachment 67343 [details]
> screenshot
> 
> I see graphic corruption in GNOME game tetravex. See attached screenshot.

From the log, the problem may be caused by that glamor treats a normal pixmap as a pixmap associated to a picture. Thus it get the picture format directly from the private data structure rather than convert one from the depth. As it's not a real picture so the private data structure holds an invalid format "9" which is not a valid picture format. This is a rare case which I had never seen it before.

Furthermore, the return value should be false, then glamor still have chance to fallback to software rendering path. But it return TRUE, so it just return with a random texture data.

I tried to reproduce it on my machine which is intel SNB machine. But I failed. Maybe our environment is not the same. My distro is FC17.i686. My game version is gnome-games-gnotravex-3.5.90-2.fc18.i686, I failed to get a fc17 version gnotravex, Maybe that's root cause why I can't reproduce this issue.
Comment 6 Zhigang Gong 2012-09-21 02:42:07 UTC
As I can't reproduce this bug, I set it to NEEDINFO status. Maybe the game's eaxct version number or even the binary package if possible, or the back trace when it hit the error messages.
Comment 7 Michel Dänzer 2014-02-27 07:29:13 UTC
Is this still an issue with current glamor? Can't reproduce it with gnome-tetravex.
Comment 8 GitLab Migration User 2018-12-13 18:24:55 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/85.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.