Bug 5389 - Khmer keyboard layout missing
Khmer keyboard layout missing
Status: RESOLVED FIXED
Product: xkeyboard-config
Classification: Unclassified
Component: General
unspecified
All Linux (All)
: high normal
Assigned To: xkb
:
: 6137 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 13:31 UTC by Jens Herden
Modified: 2006-03-05 17:36 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
symbols of the Khmer keyboard (4.44 KB, text/plain)
2005-12-20 13:33 UTC, Jens Herden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Herden 2005-12-20 13:31:06 UTC
Cambodia is moving to Unicode in its computer systems (more about this 
http://www.khmeros.info) and I would like to see the Khmer keyboard layout 
added to X.  
I will attach the file here but there is a particular problem with Khmer. There 
are some characters used that are not defined in Unicode as one codepoint but 
are represented by two codepoints. Basicly I need to create two characters from 
one keystroke. So the solution I found was to generate unused codepoints in the 
Khmer range and expand them with the help of the Compose files. This works very 
good.  
But I am unsure where to Compose files are located. I could not find them in 
the xkbdesc module. Do I have to file a bugreport against Xorg? 
So the lines I need are: 
 
 
<U17ff>	:	"&#6070;&#6086;" 
<U17fe>	:	"&#6084;&#6087;" 
<U17fd>	:	"&#6081;&#6087;" 
<U17fc>	:	"&#6075;&#6086;" 
<U17fb>	:	"&#6075;&#6087;" 
 
Probably you will not see the Khmer characters because of the lacking font. 
 
Please let me know what I can do more to get this done.
Comment 1 Jens Herden 2005-12-20 13:33:32 UTC
Created attachment 4132 [details]
symbols of the Khmer keyboard
Comment 2 Sergey V. Udaltsov 2005-12-31 12:49:00 UTC
committed to CVS
Comment 3 Jens Herden 2006-01-10 01:57:19 UTC
Thanks for the quick fix. 
 
The question about the compose file still remains for me. Where is the Compose 
file located? Can anyone give me a hint? 
Comment 4 Sergey V. Udaltsov 2006-01-10 06:36:53 UTC
> The question about the compose file still remains for me. Where is the Compose 
> file located? Can anyone give me a hint? 
/usr/share/X11/locale/*/Compose
Comment 5 Jens Herden 2006-01-17 00:24:58 UTC
(In reply to comment #4) 
> > The question about the compose file still remains for me. Where is the 
Compose  
> > file located? Can anyone give me a hint?  
> /usr/share/X11/locale/*/Compose 
 
Thanks for this. My question was meant a little bit different though. I know 
where the Compose files are on my computer but I fail to see them in CVS.  
Apparently they are not in the the xkbdesc module. Are they? 
So for which product do I have to file a bug report in order to get the lines 
included in all of the Compose files? 
 
Comment 6 Sergey V. Udaltsov 2006-01-17 05:21:35 UTC
Sorry I did not understand your question.
No, xkbdesc does not keep Compose files (well, probably it should - it is a good
question to discuss actually).
I'd file the bug regarding Compose against Input/Keyboard or smth.
Comment 7 Jens Herden 2006-03-06 12:36:04 UTC
*** Bug 6137 has been marked as a duplicate of this bug. ***