Bug 54603 - xwayland: more mouse / menu problems
Summary: xwayland: more mouse / menu problems
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: weston (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium blocker
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-06 15:54 UTC by Knut Petersen
Modified: 2013-05-20 14:56 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Knut Petersen 2012-09-06 15:54:18 UTC
Top bar menu behaviour of xorg programs running in weston is pretty buggy.

With some programs, the mouse might be used to open the menus, they look good, but it´s impossible to cause any action by clicking on the items. A popular example for that kind of programs: thunderbird.

In gwenview and konqueror the menus appear somewhere on the screen instead of being attached to the menu bar. 

If I start an old spreadsheet software (applixware), the menus are transparent but attached to the menu bar. After selecting an entry they become opaque and the selected action is taken.

cu,
 Knut
Comment 1 Kristian Høgsberg 2013-05-20 14:56:00 UTC
It sounds like most of these issues have been fixed - if not, please file a specific bug for each bug, describing in detail exactly what is not working and what the expected behavior is.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.