Bug 54739 - [snb rc6] unable to resume from suspend if rc6 is enabled
Summary: [snb rc6] unable to resume from suspend if rc6 is enabled
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Daniel Vetter
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-10 16:36 UTC by Wen-chien Jesse Sung
Modified: 2013-08-09 09:20 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wen-chien Jesse Sung 2012-09-10 16:36:51 UTC
Ref: https://launchpad.net/bugs/1008867

Asus ET2012E may fail to resume from suspend if rc6 is enabled. The failure rate is about 1/2, no matter with or without X.Org running. This issue is gone if I append i915.i915_enable_rc6=0 to kernel parameter.
Comment 1 Jesse Barnes 2012-12-12 18:48:03 UTC
Does this issue still occur with the latest drm-intel-next-queued branch?  What if you apply this patch?
https://patchwork.kernel.org/patch/1819391/
Comment 2 Wen-chien Jesse Sung 2013-01-23 08:41:50 UTC
Yes, it still occurs with the drm-intel-next-queued, no matter w/ or w/o the patch.
Comment 3 Ben Widawsky 2013-04-18 23:02:51 UTC
Since a couple months we've had a bug fix for setting the minimum RC6 voltage on SNB to 450mv. Can you please retest the latest drm-intel-nightly and see if the problem persists?
Comment 4 Wen-chien Jesse Sung 2013-04-22 04:19:52 UTC
Sure, I'll report the result.
Comment 5 Jesse Barnes 2013-04-24 16:48:30 UTC
Random patch to try.

http://lists.freedesktop.org/archives/intel-gfx/2013-April/027140.html
Comment 6 Wen-chien Jesse Sung 2013-05-14 10:51:01 UTC
Hi,

Tested with latest drm-intel-nightly(fa643cb) and drm-intel-nightly plus the patch in #c5 . No luck, system still hangs after resume.
Comment 7 Chris Wilson 2013-06-12 09:31:34 UTC
Can you please try with this patch: https://patchwork.kernel.org/patch/2707341/ as it claims to fix some instability with rc6 on SandyBridge?
Comment 8 Wen-chien Jesse Sung 2013-06-25 06:52:34 UTC
Chris,

Tested with the patch, it doesn't help.
Comment 9 Daniel Vetter 2013-08-09 09:20:20 UTC
Hopefully fixed with

commit 7dcd2677ea912573d9ed4bcd629b0023b2d11505
Author: Konstantin Khlebnikov <khlebnikov@openvz.org>
Date:   Wed Jul 17 10:22:58 2013 +0400

    drm/i915: fix long-standing SNB regression in power consumption after resume v2

Please reopen if it's still broken with this patch.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.