Bug 54970 - [NV34] EOG Eye of gnome shows black stripe in pictures with nouveau driver
Summary: [NV34] EOG Eye of gnome shows black stripe in pictures with nouveau driver
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-15 16:08 UTC by Adam Niedling
Modified: 2013-09-26 23:45 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
nVidia-173 Xorg.0.log (23.07 KB, text/x-log)
2012-09-15 16:08 UTC, Adam Niedling
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Niedling 2012-09-15 16:08:11 UTC
Created attachment 67209 [details]
nVidia-173 Xorg.0.log

Original bug reports:
https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1005292
https://bugzilla.gnome.org/show_bug.cgi?id=676938

I'm using a freshly installed Precise on a fairly old computer.

eog: 3.4.1-0ubuntu1
xserver-xorg-video-nouveau: 1:0.0.16+git20111201+b5534a1-1build2

The problem is that eog shows a black stripe in some of my jpg pictures. I
think the position of the stripe depends on the resolution of the picture. If
the resolution is high the stripe is located close to the top, if it's medium
the stripe is in the middle. If the resolution is low then there is no black
stripe. Please take a look at the sample images.

I used the printscreen button to create the eog version of the images.
There is no problem with other image viewing tools.

Sample images:

https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1005292/+attachment/3166211/+files/original.JPG

https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1005292/+attachment/3166213/+files/eog-version.png

https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1005292/+attachment/3166214/+files/original2.JPG

https://bugs.launchpad.net/ubuntu/+source/eog/+bug/1005292/+attachment/3166215/+files/eog-version_2.png

First I reported this as a Gnome bug on bugzilla.gnome.org but after some investigation it turned out that this problem only occurs with the nouveau driver. There is no problem with the official nVidia (173) driver.

dmesg: https://bugzilla.gnome.org/attachment.cgi?id=219398
sudo lspci -vvnn: https://bugzilla.gnome.org/attachment.cgi?id=219399
Comment 1 Adam Niedling 2012-09-15 16:19:25 UTC
Error message can be seen in the nouveau Xorg.0.log:
http://bugzilla-attachments.gnome.org/attachment.cgi?id=219397
Comment 2 Ilia Mirkin 2013-08-25 23:02:01 UTC
Does this still happen with newer versions of the kernel/xf86-video-nouveau?
Comment 3 Ilia Mirkin 2013-09-26 23:45:50 UTC
No response to re-test request in over a month. Closing as invalid.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.