Bug 55036 - [IVB] Cairo-Dock's icons disappear when using OpenGL backend (GLX-Dock)
Summary: [IVB] Cairo-Dock's icons disappear when using OpenGL backend (GLX-Dock)
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.0
Hardware: All Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
: 62633 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-17 22:48 UTC by lylambda
Modified: 2014-02-21 15:22 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Short video of the bug (CD opengl and intel driver) (1.82 MB, video/ogg)
2012-09-17 23:08 UTC, lylambda
Details
apitrace of the bug (2.21 MB, application/x-xz)
2013-05-28 08:21 UTC, Matthieu Baerts
Details
apitrace replay with an Intel Ironlake Mobile (50.64 KB, image/png)
2013-05-28 08:30 UTC, Matthieu Baerts
Details
Screenshot from Mesa 10, kern 3.11 (51.76 KB, image/png)
2014-02-19 23:16 UTC, k3mist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lylambda 2012-09-17 22:48:55 UTC
Chipset intel : Intel HD Graphics 4000 (with i5-3210M)
Operating System : Ubuntu 12.04 64bits


When I use the openGl backend of cairo-dock (http://glx-dock.org/), some application's icons don't was invisible. Icons appear when the cursor passes over them.
For understand, see video in attachment or here : http://videobin.org/+60v/6nt.html

This bug arn't visible with the "panel" view (no zoom effect and icons static) but

Interesting to know, this bug is visible with "3D" or "curve" view (zoom effect) but not with "panel" view (icons static).

Hope you have all informations needed !
Comment 1 lylambda 2012-09-17 23:08:33 UTC
Created attachment 67303 [details]
Short video of the bug (CD opengl and intel driver)
Comment 2 lylambda 2012-09-17 23:12:45 UTC
Edit :
some application's icons don't was invisible --> some application's icons are invisible
Comment 3 Phil 2012-09-21 09:25:09 UTC
Exact same problem for me with an I7 3610qm.

If I run it with optirun and the real graphic card, it works great. Not with the integrated one.
Comment 4 joshua_39 2012-09-22 18:46:16 UTC
Me too HD 4000 (with I5-3210M)
On ubuntu 12.04 64 bits and debian testing/sid 64 bits
Comment 5 danft2 2012-10-22 22:30:02 UTC
I was having the same problem with cairo-dock, Intel Graphics 4000, but as soon as I update cairo-dock to the 3.1 version it is working fine.
Comment 6 danft2 2012-10-22 22:55:10 UTC
(In reply to comment #5)
> I was having the same problem with cairo-dock, Intel Graphics 4000, but as
> soon as I update cairo-dock to the 3.1 version it is working fine.
>>Edit: Only working in the default mode, 3D mode is with the same problem.
Comment 7 lylambda 2012-10-28 21:56:31 UTC
I agree with danft2 : this bug is on 3D view, not with the panel view (no sure for others)
Comment 8 pcubuntoo 2012-11-29 22:43:32 UTC
I was having the same problem with cairo-dock, on CPU Ivy-Bridge.
Comment 9 sero.albert 2012-12-05 12:27:02 UTC
I am having the same problem too, I encountered the same problem in Linux Mint, and my graphics card is Nvidia 650M
Comment 10 sero.albert 2012-12-05 13:31:47 UTC
Sorry, my bad, my system is actually choose to use Intel HD Graphics 4000, not a Nvdia Card.
Comment 11 Thibault 2013-01-09 22:21:36 UTC
Hello, I have this problem too, i would like to know if the dev team is working on it?

Thanks =)


Thibault
Comment 12 Greg K 2013-02-02 13:23:15 UTC
Just wanted to add that I have the same issue and am also running Intel HD 4000 Graphics.

I'm running Arch Linux, Xfce 4.10 with Cairo dock 3.1.2.

http://imgur.com/gMmV9ZD

I started Cairo with: cairo-dock -o -i

I do not experience these issues if I use the cairo backend:
cairo-dock -c

Thanks
Comment 13 Eric Anholt 2013-03-14 07:49:47 UTC
Looks like I've reproduced it.  It's spitting warnings about visuals, so I think I want to pull down the code, but the conference wireless has kept me from getting at least 267mb of code through bzr-git.
Comment 14 Redi 2013-04-04 18:14:38 UTC
Hi,
I have the same problem, this is the terminal output on Fedora 18 >

[redi@localhost ~]$ cairo-dock

** (cairo-dock:2423): WARNING **: Can't load fallback CSS resource: Failed to import: Prostředek v „/org/gnome/adwaita/gtk-fallback.css“ neexistuje

** (cairo-dock:2423): WARNING **: Can't load fallback CSS resource: Failed to import: Prostředek v „/org/gnome/adwaita/gtk-fallback.css“ neexistuje
warning :  (/home/makerpm/rpmbuild/BUILD/cairo-dock-3.2.0/src/gldit/cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:202)  
  couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...

 ============================================================================
	Cairo-Dock version : 3.2.0
	Compiled date      : Mar 22 2013 17:47:58
	Built with GTK     : 3.6
	Running with OpenGL: 1
 ============================================================================

warning :  (/home/makerpm/rpmbuild/BUILD/cairo-dock-3.2.0/src/gldit/cairo-dock-launcher-manager.c:cairo_dock_launch_command_sync_with_stderr:448)  
  Pro „/desktop/gnome/interface/font_name“ není nastavena hodnota

pango_font_description_from_string: assertion `str != NULL' failed
pango_font_description_get_family: assertion `desc != NULL' failed
pango_font_description_get_size: assertion `desc != NULL' failed
pango_font_description_get_size_is_absolute: assertion `desc != NULL' failed
pango_font_description_get_weight: assertion `desc != NULL' failed
pango_font_description_get_style: assertion `desc != NULL' failed
warning :  (/home/makerpm/rpmbuild/BUILD/cairo-dock-3.2.0/src/gldit/cairo-dock-launcher-manager.c:cairo_dock_launch_command_sync_with_stderr:448)  
  Pro „/desktop/gnome/interface/font_name“ není nastavena hodnota

pango_font_description_from_string: assertion `str != NULL' failed
pango_font_description_get_family: assertion `desc != NULL' failed
pango_font_description_get_size: assertion `desc != NULL' failed
pango_font_description_get_size_is_absolute: assertion `desc != NULL' failed
pango_font_description_get_weight: assertion `desc != NULL' failed
pango_font_description_get_style: assertion `desc != NULL' failed
Launcher-API-Daemon: registered as Unity: <dbus.service.BusName com.canonical.Unity on <dbus._dbus.SessionBus (session) at 0xef6950> at 0xee96d0>
connect...
-> connected to cairo-dock
('new owner:', dbus.UTF8String(':1.51'))

('new owner:', dbus.String(u''))
-> no more connection to cairo-dock
[redi@localhost ~]$
Comment 15 mz0827 2013-05-03 08:40:52 UTC
Is your computer display normal?
I have the same program,and my computer isn't display normal because of the driver. can you help me?
(In reply to comment #14)
> Hi,
> I have the same problem, this is the terminal output on Fedora 18 >
> 
> [redi@localhost ~]$ cairo-dock
> 
> ** (cairo-dock:2423): WARNING **: Can't load fallback CSS resource: Failed
> to import: Prostředek v „/org/gnome/adwaita/gtk-fallback.css“ neexistuje
> 
> ** (cairo-dock:2423): WARNING **: Can't load fallback CSS resource: Failed
> to import: Prostředek v „/org/gnome/adwaita/gtk-fallback.css“ neexistuje
> warning : 
> (/home/makerpm/rpmbuild/BUILD/cairo-dock-3.2.0/src/gldit/cairo-dock-opengl.c:
> cairo_dock_initialize_opengl_backend:202)  
>   couldn't find an appropriate visual, trying to get one without Stencil
> buffer
> (it may cause some little deterioration in the rendering) ...
> 
>  ============================================================================
> 	Cairo-Dock version : 3.2.0
> 	Compiled date      : Mar 22 2013 17:47:58
> 	Built with GTK     : 3.6
> 	Running with OpenGL: 1
>  ============================================================================
> 
> warning : 
> (/home/makerpm/rpmbuild/BUILD/cairo-dock-3.2.0/src/gldit/cairo-dock-launcher-
> manager.c:cairo_dock_launch_command_sync_with_stderr:448)  
>   Pro „/desktop/gnome/interface/font_name“ není nastavena hodnota
> 
> pango_font_description_from_string: assertion `str != NULL' failed
> pango_font_description_get_family: assertion `desc != NULL' failed
> pango_font_description_get_size: assertion `desc != NULL' failed
> pango_font_description_get_size_is_absolute: assertion `desc != NULL' failed
> pango_font_description_get_weight: assertion `desc != NULL' failed
> pango_font_description_get_style: assertion `desc != NULL' failed
> warning : 
> (/home/makerpm/rpmbuild/BUILD/cairo-dock-3.2.0/src/gldit/cairo-dock-launcher-
Comment 16 AbdoRefky 2013-05-19 01:32:23 UTC
i have the same bug on I3-3110M.
this problem occure with 3D .i have recorded a video  
http://youtu.be/GyYpCG4mQoI 

i have reported a bug with files attached on the launchpad , ubuntu uploaded some files there too . 
i also found that the comments here are visible there ! how come ! 
https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1180646

i also have this setting pic. the one on the left for OpenGL , the setting on the down left cornor work only on OpenGL :(
http://imageshack.us/a/img46/4723/screenshotfrom201305150.png

i there any information should i upload to fix this bug ?
Comment 17 AbdoRefky 2013-05-19 01:33:02 UTC
ubuntu 12.04
Comment 18 AbdoRefky 2013-05-20 12:51:15 UTC
i have cairo-dock 3.2.1 
is any one reading this bug ? 

i feel that its a bug in the middle of hundered of unsorted bugs. 
there are some bugs with status new and they are since 2011 !!!

when i check the bug to see if some one wrote something . i can't find a back botton to find the category that this bug came from. which mean u have to search manually or from the bug ID , why u isolating the bug from other bugs ? 
why not simply move between subjects on the same matter like forums 
this is weird . 

is this a dead place or what ? i hope some one answer so i can atleast to know that i am not the only here . :(
Comment 19 Chris Wilson 2013-05-24 14:37:09 UTC
*** Bug 62633 has been marked as a duplicate of this bug. ***
Comment 20 AbdoRefky 2013-05-27 22:36:48 UTC
8 month's to solve a bug ?
Comment 21 Matthieu Baerts 2013-05-27 23:09:14 UTC
(In reply to comment #20)
> 8 month's to solve a bug ?

This bug is still not fixed but it seems Mesa devs are really busy, no need to insist ;)

> i there any information should i upload to fix this bug ?

An 'apitrace' can maybe be useful.

  $ apitrace trace --api=gl /usr/bin/cairo-dock


Can you also confirm that you don't have this bug when launching the dock with this command?

  $ env LIBGL_ALWAYS_SOFTWARE=1 cairo-dock -o
Comment 22 lylambda 2013-05-27 23:14:56 UTC
Maybe this .trace can help for solved the bug.
--> http://dl.free.fr/g0lgJQZOe

Ask if you need something else !
Comment 23 Matthieu Baerts 2013-05-28 08:21:51 UTC
Created attachment 79885 [details]
apitrace of the bug

Hello,

It's maybe easier if this file is directly added here (and with a better compression) ;)
Comment 24 Matthieu Baerts 2013-05-28 08:30:41 UTC
Created attachment 79886 [details]
apitrace replay with an Intel Ironlake Mobile

If I use the option 'replay' with an Intel Ironlake Mobile (i915), I don't have this problem: all icons are correctly drawn.
Comment 25 AbdoRefky 2013-05-30 01:30:36 UTC
sorry for being late , i had an exam 
here the 2 command in comment #21 
as u can see on the video that the secound command made some effects work :O
thats why i made video not ss i can make ss for both commands if u want . 
http://youtu.be/Fep3MOj4Qh8

i have downloaded the file on comment #22 but i dont know what to make with it :( 

what else can i get for you . and what to do with that file sent in comment #22
Comment 26 Matthieu Baerts 2013-05-30 08:04:20 UTC
(In reply to comment #25)
> sorry for being late , i had an exam 
> here the 2 command in comment #21 
> as u can see on the video that the secound command made some effects work :O
> thats why i made video not ss i can make ss for both commands if u want . 
> http://youtu.be/Fep3MOj4Qh8

If you only have this bug when using:
  $ cairo-dock -o

and not when using: (when "not using the hardware acceleration")
  $ env LIBGL_ALWAYS_SOFTWARE=1 cairo-dock -o

It means that it seems this bug is due to mesa/i965.

> i have downloaded the file on comment #22 but i dont know what to make with
> it :( 

These traces (produced with 'apitrace' when using the dock with the OpenGL) can be useful for Mesa/i965 devs ;)
Comment 27 AbdoRefky 2013-05-30 10:55:58 UTC
i dont have i965 , 
just i915
Comment 28 Matthieu Baerts 2013-05-30 11:11:50 UTC
But do you have an Intel IvyBridge 4000HD as everybody else who has this bug here? And are you using default video drivers of your distribution?

 $ lsmod|grep "^i"
 $ sudo lshw -C display
 $ glxinfo| grep OpenGL
Comment 29 AbdoRefky 2013-05-31 20:40:58 UTC
lsmod|grep "^i"

iwlwifi               401125  0 
i915                  475734  4 
i2c_algo_bit           13413  1 i915
----------------------------------------------
sudo lshw -C display

[sudo] password for abdo: 
  *-display               
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:43 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:3000(size=64)
--------------------------------------------------
 glxinfo| grep OpenGL

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL version string: 3.0 Mesa 9.0.1
OpenGL shading language version string: 1.30
OpenGL extensions:
Comment 30 AbdoRefky 2013-05-31 20:43:54 UTC
i have this photo too , token 2 weeks ago or so 
http://imageshack.us/photo/my-images/801/screenshotfrom201305161.png/
Comment 31 AbdoRefky 2013-05-31 20:52:32 UTC
the screen shots for the terminal command (the same as the video )

apitrace trace --api=gl /usr/bin/cairo-dock
http://imageshack.us/photo/my-images/547/screenshotfrom201305300.png/
--------------------------------------------

env LIBGL_ALWAYS_SOFTWARE=1 cairo-dock -o
http://imageshack.us/photo/my-images/600/screenshotfrom201305312.png/
Comment 32 Matthieu Baerts 2013-05-31 20:58:03 UTC
@AbdoRefky: is it possible to create a new bug report which affects Drivers/DRI/i915 because it's maybe not the same problem.

About apitrace, it should create this file in the same directory: cairo-dock.trace. Is it possible to join this file to the new bug report?


@lylambda: can you confirm that you're using this driver: i965


@Intel devs: if this bug affects i915 and i965 drivers (but ONLY with IvyBridge GPU), is it possible that this bug is due to something else?
Comment 33 lylambda 2013-06-12 20:57:02 UTC
"@lylambda: can you confirm that you're using this driver: i965"

I think so :

[lylambda@nobody ~]$ lsmod|grep "^i"
iTCO_wdt                5407  0 
iTCO_vendor_support     1929  1 iTCO_wdt
iwldvm                171209  0 
iwlwifi               135357  1 iwldvm
i2c_i801               11109  0 
i915                  550161  4 
intel_agp              10936  1 i915
intel_gtt              12680  2 i915,intel_agp
i2c_algo_bit            5391  1 i915
i2c_core               22774  5 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit
Comment 34 Matthieu Baerts 2013-06-12 21:02:55 UTC
Ok, you're also using i915 video driver!

But it only affects Ivy Bridge cards! (Intel 4000HD)

@Intel devs: is this bug due to this i915 video driver or something else?
Comment 35 lesebas 2013-06-19 19:36:55 UTC
Hello, I've encountered the same problem with my Dell Latitude E6330.

Problem solved for me by activing the acceleration methode SNA. 

[[https://wiki.archlinux.org/index.php/Intel_Graphics#Choose_acceleration_method]]
Comment 36 lesebas 2013-06-19 19:47:10 UTC
Sorry it was too simple. Actually I've launched once the cairo-dock by activating the option w/o openGL. The dock have kept in memory this choice! By forcing the option -o it's not better!
Comment 37 Ian Romanick 2013-07-09 18:10:44 UTC
i915.ko is the kernel driver used for all Intel GPUs.  i965_dri.so is the OpenGL driver used for all of the GPUs mentioned in this bug report (I see Ironlake and Ivy Bridge).

I also only see one Mesa version mentioned (9.0.1), and it's quite old.  Is anyone able to reproduce this on either 9.1.4 or current master?
Comment 38 3vi1 2013-07-14 16:44:04 UTC
I've also been able to recreate this issue while running cairo-dock on a Clevo P150EM (Intel HD4000).

I see the status is NEEDINFO.  I've worked around the issue for myself by just using the cairo back end, but is there any info/testing I can provide to help resolve the issue when using OpenGL?

evil@clevo:~$ lsmod|grep "^i"
...
i915                  610430  4 
...

evil@clevo:~$ sudo lshw -C display
[sudo] password for evil: 
  *-display               
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:45 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

evil@clevo:~$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.1.4
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.1.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
Comment 39 Ayberk Özgür 2013-07-16 14:27:44 UTC
Installing Intel Graphics Updates from ubuntu-x-swat seems to fix this problem: https://launchpad.net/~ubuntu-x-swat/+archive/intel-graphics-updates 
It features the open source Intel graphics stack 12.07 release. 

While it doesn't seem to be too stable, there are no problems (including invisible icons) with a fresh install of cairo-dock version 3.2.1 from the launchpad ppa. The problems reappear when a ~/.config/cairo-dock/ directory is ported from another existing system, and this even causes kwin to crash. I will use cairo dock further and add/remove icons and applets to see if the drivers are stable.

My driver details after installing the graphics stack updates are as follows: 

equilibrium@equbook:~$ lsmod | grep "^i"
iwlwifi               401148  0 
i915                  478239  2 
i2c_algo_bit           13423  1 i915
equilibrium@equbook:~$ sudo lshw -C display
  *-display               
       description: VGA compatible controller
       product: Ivy Bridge Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:47 memory:f0000000-f03fffff memory:e0000000-efffffff ioport:3000(size=64)
equilibrium@equbook:~$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
OpenGL version string: 2.1 Mesa 9.0.1
OpenGL shading language version string: 1.20
OpenGL extensions:
Comment 40 Ayberk Özgür 2013-07-16 14:38:23 UTC
Oops, forgot to mention that I'm on a Samsung NP900X4C which has Intel Core i7-3537U with HD 4000 GPU running a Kubuntu 12.04.2
Comment 41 Matthieu Baerts 2013-07-17 18:06:14 UTC
@Ayberk: Thank you for these details but it seems this ppa (https://launchpad.net/~ubuntu-x-swat/+archive/intel-graphics-updates) contains old packages and you're using llvmpipe:

    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
Comment 42 Matthieu Baerts 2013-07-17 18:09:11 UTC
> i965_dri.so is the OpenGL driver used for all of the GPUs mentioned in this bug report (I see Ironlake and Ivy Bridge).

@Ian Romanick: ok, thank you! But it seems this bug *only* affects Ivy Bridge GPU (Intel 4000 HD).
I'm using an Intel Ironlake Mobile and I don't have this problem.
Comment 43 Ayberk Özgür 2013-07-18 07:18:52 UTC
Updates on my tests using the ubuntu-x-swat/intel-graphics-updates ppa:

1) After some usage, kwin freezes after login. The only way I was able to solve this is to delete the ~/.kde/ folder, which resets all of the KDE settings. 
2) There's a lot of GPU usage when everything is idle. There's a lot of heating and the fan works by default (which doesn't occur with standard 12.04.2 drivers) but there's no CPU usage reported by the system monitor. 

Indeed, this ppa may be using some old packages.
Comment 44 Matthieu Baerts 2013-07-29 10:14:21 UTC
@Ian Romanick: 3vi1 is able to reproduce this bug on 9.1.4.
It only affects Ivybridge GPU (no problem with an Ironlake GPU), what can we do more?
Comment 45 3vi1 2013-09-10 19:41:25 UTC
I can also recreate it at 9.2.0 (using Ubuntu 13.10 beta).

Symptoms appear same as the original when using cairo-dock.

---------------------------------
evil@clevo:~/src/clevokbledui$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.0
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.2.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
Comment 46 Michal Gloc 2013-09-20 21:00:40 UTC
Also reproduced on Linux Mint 15 x64 Peppermint (fresh install) on Dell XPS12 (i7-3537U, Intel HD 4000). Symptoms as originally reported. Cairo-dock working well in non-OpenGL mode.
Comment 47 rodri 2013-10-15 19:26:48 UTC
I have the same problem as posted here in previous version to 3.3.1. Using opengl the icon in the bar do no appear until mouse is over.

After updating to version 3.3.1 when I launch cairo-dock from terminal, advanced configure settings are shown. Then if i want to switch to basic mode, it keeps in advanced mode, no way to switch to basic mode. Even the second time I try to switch to basic mode, it exits. Also, cairo-dock bar is not shown. Even worse than versions previous to 3.3.1.

I have kernel 3.11.5-1-ARCH x86_64. I have an intel HD4000 lvy-bridge and below intel driver installed:

extra/xf86-video-intel 2.21.15-1 (xorg-drivers xorg)

Please, fix it as soon as possible.
Comment 48 3vi1 2013-10-15 20:08:45 UTC
Problem still occurs with Mesa 9.2.1

evil@clevo:~$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.1
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.2.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
Comment 49 Matthieu Baerts 2013-10-16 11:22:42 UTC
@rodri: is it possible to give more details about this crash on Glx-Dock forums (or on Launchpad)?
Can you also produce a backtrace of this crash? => It's not complicated ;-) http://glx-dock.org/ww_page.php?p=ddd

Thank you!
Comment 50 Sigurd Holter 2013-10-25 17:06:28 UTC
This bug appeared on my computer after doing an upgrade to Ubuntu 13.10 from 13.04.
The dock was working fine before the upgrade.

  *-display               
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:47 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)


OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.1
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.2.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
Comment 51 gunwald 2013-11-26 17:21:32 UTC
Is there any hope, that this will be fixed soon? I have the same problem since I updated to Ubuntu 13.10 and with this big Cairodock became unusable. What can we do to help?
Comment 52 3vi1 2013-11-26 20:30:20 UTC
Bug also occurs with Mesa 9.2.2, in Ubuntu 14.04 pre-alpha:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.2
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.2.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
Comment 53 Matthieu Baerts 2013-11-26 21:57:59 UTC
@gunwald: unfortunately, it seems that the only solution now is to not use the OpenGL backend (by launching the dock with this command: `cairo-dock -c`) :-/
Comment 54 Chris 2013-12-23 22:13:25 UTC
I'm hitting this bug on my X1 Carbon running Fedora 20

 glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.4
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 9.2.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

I'll keep my eye on this bug and my fingers crossed for a fix!
Comment 55 k3mist 2014-02-19 23:14:03 UTC
Unfortunately, bug still exists in Mesa 10 running kern 3.11

~ # glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.0.0
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.0.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

~ # uname -r
3.11.0-14-generic
Comment 56 k3mist 2014-02-19 23:16:41 UTC
Created attachment 94391 [details]
Screenshot from Mesa 10, kern 3.11
Comment 57 3vi1 2014-02-19 23:40:21 UTC
I can hardly believe my eyes, but this bug appears to be FIXED under the current libraries in the Trusty beta.

evil@clevo:~$  glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.1.0-rc1
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.1.0-rc1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
evil@clevo:~$ uname -r
3.13.0-10-generic
Comment 58 k3mist 2014-02-20 02:55:57 UTC
evil, your comment provoked me to update via xorg edgers and I can confirm it is fixed in 10.2 as well.

~ # glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.2.0-devel
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.2.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

~ # uname -r
3.11.0-14-generic
Comment 59 3vi1 2014-02-20 12:12:58 UTC
Excellent!  It appears this bug is fixed in Mesa 10.1 and later, and can finally be closed.
Comment 60 Matthieu Baerts 2014-02-20 13:00:26 UTC
Great news!

Did you launch the dock with this command?

  $ cairo-dock -o

Because with the latest version, when launching the dock and if it detects that you're using an Intel HD Graphics 4000, OpenGL backend will not be used except if you force it with the previous command.
If you no longer have this bug, I'll be happy to remove this workaround! :-)
Comment 61 3vi1 2014-02-20 13:58:43 UTC
Yes.  :)  I definitely made sure it was using OpenGL and that I was running it on my HD4000 and not the nVidia chipset.
Comment 62 k3mist 2014-02-20 18:02:59 UTC
Same here... I personally triple checked and rebooted twice, LOL. unncessary but wanted to make sure. Guess I'll be running edgers for a bit...
Comment 63 Matthieu Baerts 2014-02-20 18:21:48 UTC
Great, thank you for your tests :-)

The blacklist is now disabled if Mesa >= 10.1 is available!
Comment 64 3vi1 2014-02-21 15:22:17 UTC
I also tested with edgers 10.2 packages, like k3mist, and it is still working perfectly.  I too rebooted and checked multiple times that everything is good.

I found other bugs with the current 10.1 packages in trusty, but they're not related to this issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.