Bug 5569 - savage: glxgears only shows monochrome flicker
Summary: savage: glxgears only shows monochrome flicker
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-11 12:05 UTC by Steffen Schwientek
Modified: 2019-10-14 13:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg's Log (42.80 KB, text/plain)
2006-01-13 09:29 UTC, Steffen Schwientek
no flags Details
output of /var/log/messages (1.54 KB, text/x-log)
2006-01-13 09:35 UTC, Steffen Schwientek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Schwientek 2006-01-11 12:05:27 UTC
If I start glxgears, there is only some kind of monochrome flicker. If I 
enlarge the glxgears window, X will be unuseble. 
However, there is a bigger problem: I need to reboot the computer to get X 
working again, since a restarted X provides me with the same unuseble screen. 
Unloading savage and drm doesn't help, neither disabling DRI completely. 
 
I use modular X, latest gentoo build. DRM and the kernel-modules are 
cvs-sources. 
 
 
 
 
Xorgs log reports the following: 
 
 
(II) SAVAGE(0): [drm] removed 1 reserved context for kernel 
(II) SAVAGE(0): [drm] unmapping 8192 bytes of SAREA 0xe0929000 at 0xb1fb4000 
(EE) SAVAGE(0): restarting S3 graphics engine reset  1 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  2 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  3 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  4 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  5 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  6 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  7 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  8 ... 
(EE) SAVAGE(0): restarting S3 graphics engine reset  9 ... 
FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.
Comment 1 Felix Kühling 2006-01-12 11:33:47 UTC
Could you attach the complete Xorg log file?
Comment 2 Steffen Schwientek 2006-01-13 09:29:57 UTC
Created attachment 4334 [details]
Xorg's Log
Comment 3 Steffen Schwientek 2006-01-13 09:35:35 UTC
Created attachment 4335 [details]
output of /var/log/messages

With a 2.6.15 the kernel crashes too. dmesg reports in addition: rebooting
likely.
Comment 4 Felix Kühling 2006-01-13 11:24:11 UTC
Some of the log is a bit confusing. I don't know where that backtrace in the
kernel log comes from. It does not seem to involve the savage or drm directly.
But the status=... line and the engine resets indicate that the engine is locked
up. You can experiment with the DmaMode and ShadowStatus options and see if they
fix the problem. Try independently of each other:

Option "DmaMode" "None"

  and

Option "ShadowStatus" "off"
Comment 5 Steffen Schwientek 2006-01-15 07:50:46 UTC
Disabling dma in xorg.conf fixes the problem. 
 
 
Comment 6 chemtech 2013-03-15 13:57:52 UTC
Steffen Schwientek 
Do you still experience this issue with newer drivers ?
Please check the status of your issue.
Comment 7 Martin Peres 2019-10-14 13:20:25 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.