Bug 55877 - Latest version from git causes issues with the displaymanagers to detect/kill plymouth. This causes strange effects on the screen
Latest version from git causes issues with the displaymanagers to detect/kill...
Status: RESOLVED FIXED
Product: plymouth
Classification: Unclassified
Component: general
unspecified
x86-64 (AMD64) Linux (All)
: medium critical
Assigned To: Ray Strode [halfline]
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 14:52 UTC by Raymond Wooninck
Modified: 2012-11-05 17:13 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raymond Wooninck 2012-10-11 14:52:05 UTC
With the latest version from git, I noticed a strange behavior of the displaymanager. I tried lightdm and also KDM, but both gave the same effect. When the displaymanager is active, I couldn't switch to any other virtual console and upon logon, the KDE splash screen was displayed with graphic artifacts (lines, etc). Once the KDE loaded, the screen became garbled and unusable. 

Checking various components, I found out that it was plymouth that was causing this behavior. It seems that the displaymanager was not able to detect that plymouth was running or couldn't kill it. (I couldn't validate this, as I couldn't switch to a different virtual console). 

I tried to bisect the git commit that caused this effect and started with the official tarball of 0.8.7. On openSUSE, the only added patch were the three commits regarding(related) using sockets instead of the pid-file. Rebuilding plymouth locally, I found that the commit to have a second start of plymouthd finish silently (and successfully) is causing this effect. 

Reverting back to having EX_UNAVAILABLE as a returnvalue, resolved the indicated issues. 

The KDM patch used is the same one as Fedora is using and I believe that lightdm is using a similar approach. I didn't had GDM installed, but all three of them are using plymouth --ping to detect if plymouth is running.
Comment 1 Ray Strode [halfline] 2012-10-12 14:12:38 UTC
Any chance you could attach the output of

systemctl dump

and

journalctl -ba

from when its sitting in the broken state ?
Comment 2 Raymond Wooninck 2012-10-17 20:30:38 UTC
Hi Ray,

Unfortunately the system is inaccessible at that moment. None of the virtual terminals seem to be working and the graphical session ends up in a non-usable session. 

Sorry about this.

Raymond
Comment 3 Ray Strode [halfline] 2012-11-05 17:13:38 UTC
we're seeing this in fedora now too:

https://bugzilla.redhat.com/show_bug.cgi?id=870695

I've fixed it with this commit I believe:

http://cgit.freedesktop.org/plymouth/commit/?id=a6129abfc527ac247685d80fc5c20144be1badca

But i'm still getting a separate occasional hang up which I believe to be a GDM problem. I'm investigating it now.