Bug 55978 - Filled acroform with XFA dataset shows old values if opened in acroread
Summary: Filled acroform with XFA dataset shows old values if opened in acroread
Status: RESOLVED DUPLICATE of bug 18935
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-14 18:24 UTC by Fabio D'Urso
Modified: 2014-03-05 23:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Test case (238.79 KB, text/plain)
2012-10-14 18:24 UTC, Fabio D'Urso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio D'Urso 2012-10-14 18:24:14 UTC
Created attachment 68557 [details]
Test case

If you edit the attached form in Poppler, the resulting file still shows the previous data when opened in acroread.

Steps to reproduce: Open file with poppler, change "12345" to "67890", save. Open resulting file in acroread, notice that it still shows "12345".

Some quick tests show that it's because acroread looks at the XFA dataset object (obj 66) instead of the /V property we set. Object 66 contains:

<xfa:datasets xmlns:xfa="http://www.xfa.org/schema/xfa-data/1.0/">
 <xfa:data>
  <Formular1>
   <Textfeld1>12345</Textfeld1>
   <Textfeld1/>
  </Formular1>
 </xfa:data>
</xfa:datasets>
Comment 1 Jean-François Fortin Tam 2014-03-05 23:12:59 UTC

*** This bug has been marked as a duplicate of bug 18935 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.