Bug 55993 - xorg-server 1.13.0 separate X screens: mouse stuck on primary display
Summary: xorg-server 1.13.0 separate X screens: mouse stuck on primary display
Status: RESOLVED DUPLICATE of bug 54654
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 08:30 UTC by Thomas Kuther
Modified: 2012-10-17 11:45 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kuther 2012-10-15 08:30:44 UTC
After a recent update from xorg-server-1.12.4 to xorg-server-1.13.0, running a separate X screen setup with a left (primary) and right (TV) monitor, it is not possible anymore to move the mouse over the right border of the left screen to the right screen. Instead, the mouse pointer jumps to the left border of the left screen, at the same vertical position.

This is related to separate X screens only. Xinerama/TwinView seems to work.
It's not related to nvidia blob, as users of Nouveau and ATI are affected too.

Downgrading xorg-server to 1.12.4 solves this. Evdev version before and after the upgrade is/was 2.7.3 - just recompiled. 

Arch Linux Bug:
- https://bugs.archlinux.org/task/31959

Some more user reports:
- http://forums.gentoo.org/viewtopic-p-7163594.html
- https://bbs.archlinux.org/viewtopic.php?id=150416
Comment 1 Till Matthiesen 2012-10-17 11:38:10 UTC
Any chance this is a duplicate of this bug report?

"Pointer screen crossings broken in Xorg server 1.13.0 (regression)"
https://bugs.freedesktop.org/show_bug.cgi?id=54654

~Till
Comment 2 Thomas Kuther 2012-10-17 11:45:58 UTC
Indeed. Didn't search for zaphod and pointer but mouse and separate xscreen instead. Gargleblasting now.

*** This bug has been marked as a duplicate of bug 54654 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.