Bug 56081 - (SUMO2) Black screen on X Launch, corrupted VTs when using KMS
Summary: (SUMO2) Black screen on X Launch, corrupted VTs when using KMS
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2012-10-17 11:16 UTC by Tony Thomas
Modified: 2019-11-19 08:29 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg.0.log (52.89 KB, text/plain)
2012-10-17 11:16 UTC, Tony Thomas
no flags Details
dmesg, booted drm.debug=6 (118.11 KB, text/plain)
2012-10-17 11:17 UTC, Tony Thomas
no flags Details
Ubuntu updated Xorg.0.log (54.58 KB, text/plain)
2012-10-17 14:49 UTC, Tony Thomas
no flags Details
3.7.0-rc1 dmesg (no debug) (66.76 KB, text/plain)
2012-10-17 14:50 UTC, Tony Thomas
no flags Details
3.7.0-rc1 dmesg (drm.debug=6) (115.48 KB, text/plain)
2012-10-17 14:55 UTC, Tony Thomas
no flags Details
Debian Sid w/3.6.8-pf dmesg (drm.debug=6) (104.80 KB, text/plain)
2012-11-05 19:30 UTC, Tony Thomas
no flags Details
Debian Sid w/3.6.8-pf xorg.0.log (fail) (52.60 KB, text/plain)
2012-11-05 19:32 UTC, Tony Thomas
no flags Details
dmesg drm.debug=6 (35.10 KB, text/plain)
2012-12-30 17:00 UTC, Tony Thomas
no flags Details
Xorg.0.log (46.28 KB, text/plain)
2012-12-30 17:02 UTC, Tony Thomas
no flags Details

Description Tony Thomas 2012-10-17 11:16:28 UTC
Created attachment 68683 [details]

Using AMD A4-3420M APU, have NOT been able to use the R600 driver on either Suse (12.x, factory), Arch Linux (latest built, or git xorg/mesa/dri build), or Ubuntu (12.04, 12.10b2). ALL various combinations of xorg 1.12/1.13, xorg-video-ati, mesa, and kernel 3.5-3.6 give the same black screen after startup, transition to Xorg corrupts all VT's. 

KMS for Single user or non-X sessions works fine. Grub boot with "radeon.audio=0" does alleviate some corruption on VT7 (but not enough to be usable). Changing accel options or even disabling accel has no effect.

Appears there is something specific to the A4-3420M(6410D, chipID 0x9644, identified by system as a Sumo2) that is affected by this.
Comment 1 Tony Thomas 2012-10-17 11:17:03 UTC
Created attachment 68684 [details]
dmesg, booted drm.debug=6
Comment 2 Alex Deucher 2012-10-17 14:04:34 UTC
Can your try kernel 3.7?  There were some fixes that went in that may help.
Comment 3 Tony Thomas 2012-10-17 14:48:18 UTC
(In reply to comment #2)
> Can your try kernel 3.7?  There were some fixes that went in that may help.

Still the same. Upgraded xorg on Ubuntu (from xorg-edgers ppa), added 3.7.0-rc1 mainline kernel from Ubuntu kernel team.
Comment 4 Tony Thomas 2012-10-17 14:49:28 UTC
Created attachment 68713 [details]
Ubuntu updated Xorg.0.log
Comment 5 Tony Thomas 2012-10-17 14:50:23 UTC
Created attachment 68714 [details]
3.7.0-rc1 dmesg (no debug)
Comment 6 Tony Thomas 2012-10-17 14:55:25 UTC
Created attachment 68717 [details]
3.7.0-rc1 dmesg (drm.debug=6)
Comment 7 Alex Deucher 2012-11-02 13:24:17 UTC
Can you try a mesa 8.0.x release?  This might be a duplicate of bug 56405.
Comment 8 Tony Thomas 2012-11-05 19:30:29 UTC
Created attachment 69579 [details]
Debian Sid w/3.6.8-pf dmesg (drm.debug=6)

Switched system to Debian Sid, clean install. Sid is tracking 8.0.5-1 mesa

Screen corruption still, using Sid 3.2.0-4 stock kernel, and 3.6.8-pf kernel from here: http://kernel.night-leshiy.ru/

Attaching drm.debug=6 dmesg from Debian 3.6.8-pf kernel
Comment 9 Tony Thomas 2012-11-05 19:32:13 UTC
Created attachment 69580 [details]
Debian Sid w/3.6.8-pf xorg.0.log (fail)

Xorg.0.log from above failure (Debian Sid, 3.6.8-pf kernel)
Comment 10 Tony Thomas 2012-11-05 19:34:13 UTC
Of note: with most kernel combo and 8.0 mesa branch (also tried on Arch Linux), failures and corruption DO NOT prevent VT-switching as the 9.0 branch does.
Comment 11 Tony Thomas 2012-12-30 17:00:23 UTC
Created attachment 72306 [details]
dmesg drm.debug=6

Still same issue, linux-3.8-rc1. Can see mouse on black background. Cannot switch VTs.

xorg-server 1.13.1
ati-dri (mesa ATI driver) 9.0.1
Comment 12 Tony Thomas 2012-12-30 17:02:31 UTC
Created attachment 72307 [details]

xorg log. Not using any custom directives in xorg.conf (blank)
Comment 13 wojtek 2013-10-02 00:53:04 UTC
you can try
Comment 14 Martin Peres 2019-11-19 08:29:54 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/307.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.