Bug 5622 - xorg-server needs to build with -D__GLX_ALIGN64, otherwise libglx.so can generate Bus errors
xorg-server needs to build with -D__GLX_ALIGN64, otherwise libglx.so can gene...
Status: RESOLVED DUPLICATE of bug 8392
Product: xorg
Classification: Unclassified
Component: Build/Modular
SPARC Linux (All)
: high normal
Assigned To: Xorg Project Team
Xorg Project Team
Depends on:
  Show dependency treegraph
Reported: 2006-01-17 04:38 UTC by Ferris McCormick
Modified: 2008-07-07 04:11 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Ferris McCormick 2006-01-17 04:38:18 UTC
Sparc needs double precision items to be aligned mod64, so when building
libglx.so (and hw/dmx) in xorg-server, __GLX_ALIGN64 must be defined. 
Otherwise, depending on the compiler used to build xorg-server and other random
events, libglx.so might work or it might generate Bus errors (Signal 10) which
kill Xserver.  This is the same as hw/xfree86/doc/changelogs/CHANGELOG, entry 417.
Comment 1 Ferris McCormick 2006-01-17 08:01:23 UTC
By popular demand, I am expanding this to ask about the status of other 64-bit
architectures, such as alpha, ia64, amd64, mips, ppc64.  They might run into the
same problem, but I am not in a position to test them.
Comment 2 Donnie Berkholz 2006-01-17 08:18:39 UTC
From the imake...

#if BuildGlxExt
#  if defined(SparcArchitecture)  \
   || defined (Sparc64Architecture) \
   || defined(ia64Architecture) \
   || defined(s390xArchitecture) \
   || defined(AMD64Architecture)
#    define GlxArchDefines -D__GLX_ALIGN64
#  elif defined(AlphaArchitecture)
/* On the Alpha we need to ensure floating point accuracy for 3D */
#    define GlxArchDefines -D__GLX_ALIGN64 -mieee
#  elif defined(DarwinArchitecture)
/* GLX contains lots of uninitialized globals, which can upset Darwin */
#    define GlxArchDefines -fno-common
Comment 3 Daniel Stone 2007-02-27 01:30:01 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 4 Michel Dänzer 2008-07-07 04:11:51 UTC

*** This bug has been marked as a duplicate of bug 8392 ***