Bug 56265 - Overprinted characters in PDF files from latex
Summary: Overprinted characters in PDF files from latex
Status: RESOLVED FIXED
Alias: None
Product: cairo
Classification: Unclassified
Component: pdf backend (show other bugs)
Version: 1.12.6
Hardware: Other All
: medium normal
Assignee: Adrian Johnson
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-21 22:06 UTC by Johan Brannlund
Modified: 2013-02-04 09:07 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
tex file for reproducing bug (213 bytes, text/plain)
2012-10-21 22:06 UTC, Johan Brannlund
Details
PDF output from pdflatex (42.42 KB, application/pdf)
2012-10-21 22:07 UTC, Johan Brannlund
Details
PDF output from pdftocairo (67.44 KB, application/pdf)
2012-10-21 22:08 UTC, Johan Brannlund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Brannlund 2012-10-21 22:06:46 UTC
Created attachment 68888 [details]
tex file for reproducing bug

I noticed when printing a PDF file produced with latex that certain characters are printed on top of each other when printing from Evince. This can be reproduced in the following way:

1. Run "pdflatex aa.tex"
2. Run "pdftocairo -pdf aa.pdf cc.pdf"
3. Notice that the output cc.pdf contains overprinted characters when viewed on screen, whereas aa.pdf looks fine.

This is with poppler version 0.20.4, cairo version 1.12.2 and pdflatex from TexLive 2012.
Comment 1 Johan Brannlund 2012-10-21 22:07:36 UTC
Created attachment 68889 [details]
PDF output from pdflatex
Comment 2 Johan Brannlund 2012-10-21 22:08:03 UTC
Created attachment 68890 [details]
PDF output from pdftocairo
Comment 3 Benjamin Berg 2012-10-22 08:41:20 UTC
From the result it looks like the width of the embedded beta character is wrong. Note that all other cairo output devices (tested ps, svg, x11) work fine for me.

An even simple test document is to just put two beta characters in the document. You can see then, that the beta character still does have a width, but it is much too small.
Comment 4 Adrian Johnson 2012-10-26 12:41:36 UTC
Fixed in 
http://cgit.freedesktop.org/cairo/commit/?id=d57e652f
Comment 5 Albert Astals Cid 2012-10-26 12:54:15 UTC
Setting as "not our bug" since it was actually a bug in cairo, note that as per Adrian's comment it is been already fixed in cairo upstream
Comment 6 Adrian Johnson 2012-10-26 22:39:57 UTC
(In reply to comment #5)
> Setting as "not our bug" since it was actually a bug in cairo, note that as
> per Adrian's comment it is been already fixed in cairo upstream

I changed the product to cairo at the same time as I pushed a fix.
Comment 7 Serge Gavrilov 2013-02-04 09:07:52 UTC
Commit http://cgit.freedesktop.org/cairo/commit/?id=d57e652f08f5ff7c334d01bc071962e6a131928f, which fixes the current bug causes bug #60248


bug/show.html.tmpl processed on Jun 29, 2016 at 07:15:18.
(provided by the Example extension).