Bug 5635 - Numlock toggles Numlock/Scrolllock (LEDs)
Summary: Numlock toggles Numlock/Scrolllock (LEDs)
Alias: None
Product: xkeyboard-config
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: high normal
Assignee: xkb
QA Contact:
: 6162 (view as bug list)
Depends on:
Reported: 2006-01-17 18:34 UTC by Stefan Dirsch
Modified: 2008-12-17 08:39 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Description Stefan Dirsch 2006-01-17 18:34:40 UTC
After updating from xkeyboard-config 0.6 to xkeyboard-config 0.7 and  
restarting the Xserver pressing Numlock key toggles Numlock and Scrolllock  
(LEDs). It should only toggle Numlock (LED).  
Section "InputDevice"  
  Driver       "kbd"  
  Identifier   "Keyboard[0]"  
  Option       "Protocol" "Standard"  
  Option       "XkbLayout" "de"  
  Option       "XkbModel" "pc105"  
  Option       "XkbRules" "xfree86"  
  Option       "XkbVariant" "nodeadkeys"  
xkeyboard-config is built with 
./configure --with-xkb-rules-symlink=xfree86 
            --with-xkb-base=/etc/X11/xkb \ 
            --enable-compat_rules \ 
I'm using X.Org 6.9.0, but this shouldn't matter since downgrading to  
xkeyboard-config 0.6 resolves this issue.
Comment 1 Stefan Dirsch 2006-01-19 05:41:51 UTC
Removing all level5 files and all references to them (looks like a new feature) 
seems to fix this issue. Sergej, still no idea, what can be wrong here? 
Comment 2 Sergey V. Udaltsov 2006-01-19 06:00:55 UTC
Yes, level5 is the new feature introduced for supporting huge Canadian layout. I
will have a look and try to find out what's wrong... Sure, ideas are welcome. It
is an alpha-quality hack, so may well be buggy
Comment 3 Stefan Dirsch 2006-01-20 17:01:15 UTC
Using this patch fixes the issue for me. 
diff -u -r xkb.orig/types/complete xkb/types/complete  
--- xkb.orig/types/complete     2006-01-20 06:52:12.000000000 +0100  
+++ xkb/types/complete  2006-01-20 07:06:51.000000000 +0100  
@@ -11,6 +11,5 @@  
     include "mousekeys"  
     include "pc"  
     include "iso9995"  
-    include "level5"  
     include "extra"  
I'm using  
# setxkbmap "de(nodeadkeys)" -v  
Warning! Multiple definitions of keyboard layout  
         Using command line, ignoring X server  
Trying to build keymap using the following components:  
keycodes:   xfree86+aliases(qwerty)  
types:      complete  
compat:     complete  
symbols:    pc(pc105)+de(nodeadkeys)  
geometry:   pc(pc105)  
So this looks like a bug in types/level5. 
Comment 4 Sergey V. Udaltsov 2006-01-22 11:18:11 UTC
Ok, I can confirm the bug exists. Trying to find what's wrong. I did not notice
it myself because none of my keyboards have scroll LED :)
Comment 5 Sergey V. Udaltsov 2006-01-23 04:47:58 UTC
It seems I've fixed it by adding ScrollLock into the list of virtual_modifiers
in types/level5 (yeah, just added it there - without any actual use!). The bad
thing is that I do not really understand why it helps. At this time, I don't
have much time to investigate it more - so explanations are welcome ;)
Comment 6 Sergey V. Udaltsov 2008-12-17 08:39:46 UTC
*** Bug 6162 has been marked as a duplicate of this bug. ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.