Bug 56634 - r600g: fix abysmal performance in Reaction Quake : Huge slowdown
Summary: r600g: fix abysmal performance in Reaction Quake : Huge slowdown
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-01 10:39 UTC by Bruno Jacquet (Xaapyks)
Modified: 2013-03-02 19:41 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Jacquet (Xaapyks) 2012-11-01 10:39:41 UTC
http://cgit.freedesktop.org/mesa/mesa/commit/?id=fa58644855e44830e0b91dc627703c236fa6712a

Huge slowdown in Unigine-heaven (from ~25 fps to ~3 fps)
Comment 1 Andy Furniss 2012-11-01 19:21:20 UTC
I see some slowdowns with etqw (can't test heaven) on HD4890 that seem to be caused by this.

It's not constant - in fact mostly etqw with current head is the fastest I've ever seen it.

It may, however, during a short timenetdemo just suddenly drop to 4fps for a few seconds, or it may start slow ~10fps then go full speed.

With this reverted I haven't seen any slowdowns (yet).
Comment 2 Alexandre Demers 2012-11-02 01:11:04 UTC
Do you mean it's slower than without the commit or is it running mostly at the same speed when it's slowing down?
Comment 3 Andy Furniss 2012-11-02 10:43:01 UTC
(In reply to comment #2)
> Do you mean it's slower than without the commit or is it running mostly at
> the same speed when it's slowing down?

It's way slower than without the commit, but only temporarily then it recovers.

In case you have etqw, I am testing @1920x1080 fullscreen with everything turned on/up as high as possible.

I've found another issue, but it's not related to this or llvm and could be quite old as I've not left etqw running for ~30 mins for some months.

The issue is I run out of mem (4 gig). I'll open a new bug when I've had more time to test with older kernels.
Comment 4 Bruno Jacquet (Xaapyks) 2012-11-17 15:24:33 UTC
Also affects Xonotic.
Comment 5 Bruno Jacquet (Xaapyks) 2012-12-17 22:23:50 UTC
Using kernel from linus's repo fixes this issue.
Not sure if it is a "proper" fix, so I'll let you close the repoer if it should be closed.

(now I'm getting 40 fps in heaven , nice boost if we forget about the 3 fps thing)
Comment 6 Andy Furniss 2012-12-19 11:34:36 UTC
(In reply to comment #5)
> Using kernel from linus's repo fixes this issue.
> Not sure if it is a "proper" fix, so I'll let you close the repoer if it
> should be closed.
> 
> (now I'm getting 40 fps in heaven , nice boost if we forget about the 3 fps
> thing)

etqw is also running normally again with drm-next kernel and current mesa/llvm.
Comment 7 Bruno Jacquet (Xaapyks) 2013-03-02 19:41:33 UTC
Using linux 3.8 fixes this so I'm closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.