Bug 56741 - Software rendering and Wayland clients no longer work
Summary: Software rendering and Wayland clients no longer work
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-04 15:09 UTC by n3rdopolis
Modified: 2016-07-17 00:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description n3rdopolis 2012-11-04 15:09:40 UTC
Hi. It seems that the clients that come with Wayland no longer work on Mesa. 

For the longest time, to keep wayland working, and QT compiling without failing with the opengl es 2.0 functionality test failed, I was using and specifing my build scripts to use mesa comit cd4a61100da889afec96dc79b33a88b7b8049cec, because it seems that was a few commits before some commits that looked related. 

Now that Wayland 1.0 is released, I had to use master. QT no longer fails with functionality tests failing, however the clients that come with weston, when they are using software rendering, they no longer work, as I would get egl_not_initialized. 

In an attempt to work around this, I tried to apply the three patches from commits

e20a0f14b5fdbff9afa5d0d6ee35de8728f6a200 ( http://cgit.freedesktop.org/mesa/mesa/commit/?id=e20a0f14b5fdbff9afa5d0d6ee35de8728f6a200 )

2b8e90a33826dcd30b0cbbf464fbd191bf299d38  ( http://cgit.freedesktop.org/mesa/mesa/commit/?id=2b8e90a33826dcd30b0cbbf464fbd191bf299d38 )

and

0229e3ae41be109ac423b2eb2ddf79e24b799d60 ( http://cgit.freedesktop.org/mesa/mesa/commit/?id=0229e3ae41be109ac423b2eb2ddf79e24b799d60 )

to the cd4a61100da889afec96dc79b33a88b7b8049cec comit, and weston clients will still fail

At first I thought this was a weston bug, as I could get weston clients working by using  --with-cairo-glesv2 , however, now that SDL has been ported to wayland 1.0 as well, the sample client that sdl builds, testgles, also fails under software rendering
Comment 1 n3rdopolis 2016-07-17 00:11:12 UTC
Software rendering is working with Wayland clients. It's been working for years, but I forgot I still had this open


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.