Bug 57031 - [ivb GT2] [SNA] __kgem_bo_map__gtt: failed to retrieve GTT offset for handle[...]
Summary: [ivb GT2] [SNA] __kgem_bo_map__gtt: failed to retrieve GTT offset for handle[...
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Chris Wilson
QA Contact: Xorg Project Team
Depends on:
Reported: 2012-11-12 19:45 UTC by Michael Laß
Modified: 2012-11-13 09:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Full Xorg.0.log (gziped) (822.08 KB, application/x-gzip)
2012-11-12 19:45 UTC, Michael Laß
no flags Details

Description Michael Laß 2012-11-12 19:45:27 UTC
Created attachment 69959 [details]
Full Xorg.0.log (gziped)

This bug is a follow up to #54808.

I'm still using Fedora 17 on a notebook with an ivb GT2 and I'm still using that old cairo version 1.10.2 (sorry). Again it is not possible to view the large NASA picture (http://marsrovers.jpl.nasa.gov/gallery/press/opportunity/20120705a/PIA15689_Greeley_Pan_wDeck_L257F.jpg) using eog, but now I'm getting a new error message in Xorg.0.log:

__kgem_bo_map__gtt: failed to retrieve GTT offset for handle=54: 7

The handle number differs from time to time. The full Xorg.0.log is attached.

I tested ver. 2.20.10 of the driver and the latest version from git (66eb0adff...) and got the same result.

Viewing the picture worked perfectly after bug #54808 was fixed. I'm not sure what update since then led to the problem. I got a new kernel (3.6.6 instead of 3.5.3) but I can reproduce the issue with kernel 3.3.4 (unfortunately I don't have 3.5.3 anymore), so it's unlikely that kernel 3.6 causes the trouble.

I'd be glad to help tracking down the problem but if the old cairo version causes the trouble and you say it's no longer supported, that's also fine for me.
Comment 1 Chris Wilson 2012-11-13 09:25:09 UTC
Hmm, no it is just the most convenient means to trigger a bug in the ddx. Ok, can reproduce with cairo-1.10 as well...
Comment 2 Chris Wilson 2012-11-13 09:49:42 UTC
commit 2954f15e2bcb590a90c2cb6077c0843ee25a4413
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Nov 13 09:46:19 2012 +0000

    sna: Specialise the decision for inplace xor uploads
    Fixes a regression from
    commit 0be1d964713ca407f029278a8256d02d925dc9da
    Author: Chris Wilson <chris@chris-wilson.co.uk>
    Date:   Tue Sep 11 21:48:24 2012 +0100
        sna: Use inplace X tiling for LLC uploads
    which introduced the ability to swizzle into CPU maps, but also
    convinced the xorg path to the same - which for large images blows up.
    Reported-by: Michael Laß <bevan@bi-co.net>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=57031
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.