Bug 57044 - build failure: make[4]: *** No rule to make target `../../src/mesa/program/libprogram.la', needed by `libmesagallium.la'. Stop.
build failure: make[4]: *** No rule to make target `../../src/mesa/program/li...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Other
git
Other All
: medium normal
Assigned To: mesa-dev
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 03:22 UTC by Darxus
Modified: 2013-01-10 18:43 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Simple patch to fix libprogram build (1.56 KB, patch)
2012-11-28 15:46 UTC, Quentin "Sardem FF7" Glidic
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Darxus 2012-11-13 03:22:35 UTC
"907844107252260c646aca361191ef7f121f3d23 is the first bad commit" - git bisect run
"automake,android: Build program/ into a helper lib (v2)"

Using my build test script, which starts by deleting the install prefix, and running "git clean -xfd" on all the repos.

Built with:  ./autogen.sh --prefix=$WLD --enable-gles2 --disable-gallium-egl --with-egl-platforms=wayland,x11,drm --enable-gbm --enable-shared-glapi --wi
th-gallium-drivers=r300,r600,swrast,nouveau,svga

Problem also exists in the latest commit:  6991c2922f530d88622900039c24bd04d9c15ce7
Comment 1 Eric Anholt 2012-11-13 03:37:25 UTC
commit 3a5ad21cd3f026579eeacc25b39513711556c7ee
Author: Eric Anholt <eric@anholt.net>
Date:   Mon Nov 12 19:32:58 2012 -0800

    mesa: Fix gallium build since 6991c2922f
    
    Looks like I screwed up and didn't test gallium again after tweaking the
    Makefile.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=57044
Comment 2 Darxus 2012-11-13 03:57:41 UTC
Verified fixed with commit 3a5ad21cd3f026579eeacc25b39513711556c7ee, thanks.
Comment 3 Fabio Pedretti 2012-11-13 10:27:16 UTC
I have what seems the same issue with current git:

  CPPAS  read_rgba_span_x86.lo
make[5]: *** No rule to make target `../../src/mesa/program/libprogram.la', needed by `libmesa.la'.  Stop.

Full build log:
https://launchpadlibrarian.net/122918035/buildlog_ubuntu-precise-i386.mesa_9.1~git1211131112.fe2ef4~gd~p_FAILEDTOBUILD.txt.gz

Let me know if I have to open a new bug.
Comment 4 Kevin Hobbs 2012-11-13 14:09:19 UTC
(In reply to comment #3)
> I have what seems the same issue with current git:
> 

Same here, also with an xlib build.

The head of my build script is:

rm -rf /home/kevin/mesa_nightly/*

# Update Mesa Source
cd /home/kevin/mesa
make clean
git reset --hard
git clean -fd
git pull origin

# Make Mesa
./autogen.sh \
  --prefix=/home/kevin/mesa_nightly \
  --disable-dri \
  --enable-glx \
  --enable-xlib-glx \
  --without-gallium-drivers \
  --enable-osmesa \
  --disable-shared-glapi
Comment 5 Jon TURNEY 2012-11-21 19:58:18 UTC
(In reply to comment #1)
> commit 3a5ad21cd3f026579eeacc25b39513711556c7ee
> Author: Eric Anholt <eric@anholt.net>
> Date:   Mon Nov 12 19:32:58 2012 -0800
> 
>     mesa: Fix gallium build since 6991c2922f
>     
>     Looks like I screwed up and didn't test gallium again after tweaking the
>     Makefile.
>     
>     Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=57044

This change doesn't seem to be correct.

Reading src/mesa/Makefile.am, it looks to me like it will need libprogram.la if NEED_LIBMESA or HAVE_GALLIUM is true.
Comment 6 Quentin "Sardem FF7" Glidic 2012-11-28 15:46:53 UTC
Created attachment 70736 [details] [review]
Simple patch to fix libprogram build

Attached a patch to fix both build by introducing a new NEED_LIBPROGRAM Automake conditional
Comment 7 Fabio Pedretti 2012-11-28 17:27:44 UTC
(In reply to comment #6)
> Created attachment 70736 [details] [review] [review]
> Simple patch to fix libprogram build

Confirmed working.
Comment 8 Brad King 2013-01-03 13:40:43 UTC
(In reply to comment #6)
> Created attachment 70736 [details] [review] [review]
> Simple patch to fix libprogram build
> 
> Attached a patch to fix both build by introducing a new NEED_LIBPROGRAM
> Automake conditional

I have the same problem Kevin reported in comment #4 and Quentin's patch fixes it as Fabio reported in comment #7.  Please apply or explain why it's wrong.
Comment 9 Fabio Pedretti 2013-01-09 19:23:08 UTC
> Please apply or explain why it's wrong.

I agree. Applying yourself a patch is easy, but it is much less fun doing it when bisecting.
Comment 10 Kenneth Graunke 2013-01-10 18:43:56 UTC
I went ahead and committed it.  Presumably no one had bothered to do it because it didn't affect their builds.

commit c5e9396424bb470ec55a2a29e3ef95aa76fed738
Author: Quentin Glidic <sardemff7+git@sardemff7.net>
Date:   Wed Nov 28 16:33:47 2012 +0100

    mesa/program: Fix both Classic and Gallium build
    
    Follow-up for 907844107252260c646aca361191ef7f121f3d23 and
    3a5ad21cd3f026579eeacc25b39513711556c7ee
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=57044
    Tested-by: Fabio Pedretti <fabio.ped@libero.it>
    Tested-by: Brad King <brad.king@kitware.com>