Bug 57077 - PolkitAgent-1.0.gir doesn't depend on libpolkit-agent-1.la, breaking make -j
Summary: PolkitAgent-1.0.gir doesn't depend on libpolkit-agent-1.la, breaking make -j
Status: RESOLVED FIXED
Alias: None
Product: PolicyKit
Classification: Unclassified
Component: libpolkit (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: David Zeuthen (not reading bugmail)
QA Contact: David Zeuthen (not reading bugmail)
URL:
Whiteboard:
Keywords:
: 54525 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-13 16:47 UTC by Allison Lortie (desrt)
Modified: 2012-11-22 13:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
[PATCH] build: Fix .gir generation for parallel make (1.24 KB, patch)
2012-11-13 16:51 UTC, Allison Lortie (desrt)
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Allison Lortie (desrt) 2012-11-13 16:47:38 UTC
Looks like the .gir doesn't depend on the .la in Makefile.am, causing failures to 'make -j' if the race goes badly...

make[4]: Entering directory `/home/desrt/jhbuild/checkout/polkit/src/polkitagent'
  CC     libpolkit_agent_1_la-polkitagentenumtypes.lo
  CC     libpolkit_agent_1_la-polkitagentmarshal.lo
  CC     libpolkit_agent_1_la-polkitagentsession.lo
  CC     libpolkit_agent_1_la-polkitagenttextlistener.lo
  CC     libpolkit_agent_1_la-polkitagentlistener.lo
  CC     polkit_agent_helper_1-polkitagenthelperprivate.o
  CC     polkit_agent_helper_1-polkitagenthelper-pam.o
  GISCAN PolkitAgent-1.0.gir
polkitagenthelperprivate.c: In function ‘send_dbus_message’:
polkitagenthelperprivate.c:58:3: warning: ‘g_type_init’ is deprecated (declared at /opt/ca/desrt/gnome-3.8/include/glib-2.0/gobject/gtype.h:669) [-Wdeprecated-declarations]
  CCLD   polkit-agent-helper-1
polkitagentlistener.c: In function 'polkit_agent_listener_register_with_options':
polkitagentlistener.c:426:7: warning: 'g_thread_create' is deprecated (declared at /opt/ca/desrt/gnome-3.8/include/glib-2.0/glib/deprecated/gthread.h:100): Use 'g_thread_new' instead [-Wdeprecated-declarations]
polkitagentsession.c: In function 'polkit_agent_session_response':
polkitagentsession.c:570:9: warning: ignoring return value of 'write', declared with attribute warn_unused_result [-Wunused-result]
polkitagentsession.c:572:11: warning: ignoring return value of 'write', declared with attribute warn_unused_result [-Wunused-result]
  CCLD   libpolkit-agent-1.la
libtool: link: cannot find the library `libpolkit-agent-1.la' or unhandled argument `libpolkit-agent-1.la'
linking of temporary binary failed: Command '['/bin/bash', '../../libtool', '--mode=link', '--tag=CC', '--silent', 'gcc', '-o', '/home/desrt/jhbuild/checkout/polkit/src/polkitagent/tmp-introspectiVyqhN/PolkitAgent-1.0', '-export-dynamic', '-Wl,--as-needed', '-L/opt/ca/desrt/gnome-3.8/lib', '-L/opt/ca/desrt/gnome-3.8/lib', '/home/desrt/jhbuild/checkout/polkit/src/polkitagent/tmp-introspectiVyqhN/PolkitAgent-1.0.o', '-L.', 'libpolkit-agent-1.la', '-Wl,--export-dynamic', '-pthread', '-L/opt/ca/desrt/gnome-3.8//lib', '-lgio-2.0', '-lgobject-2.0', '-lgmodule-2.0', '-lrt', '-lglib-2.0']' returned non-zero exit status 1
make[4]: *** [PolkitAgent-1.0.gir] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/home/desrt/jhbuild/checkout/polkit/src/polkitagent'
make[3]: Leaving directory `/home/desrt/jhbuild/checkout/polkit/src/polkitagent'
make[2]: Leaving directory `/home/desrt/jhbuild/checkout/polkit/src'
make[1]: Leaving directory `/home/desrt/jhbuild/checkout/polkit'

I'll attach a patch.
Comment 1 Allison Lortie (desrt) 2012-11-13 16:51:41 UTC
Created attachment 70012 [details] [review]
[PATCH] build: Fix .gir generation for parallel make

As per the intructions in the introspection Makefile, we should have a
line declaring a dependency between the .gir and .la files.
Comment 2 David Zeuthen (not reading bugmail) 2012-11-13 17:06:39 UTC
Committed - thanks!
Comment 3 Samuli Suominen 2012-11-22 13:24:53 UTC
*** Bug 54525 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.