Bug 57679 - EQ overflow when start X with KMS-enabled radeon
EQ overflow when start X with KMS-enabled radeon
Status: RESOLVED DUPLICATE of bug 56720
Product: xorg
Classification: Unclassified
Component: Driver/Radeon
git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: xf86-video-ati maintainers
Xorg Project Team
http://www.linuxquestions.org/questio...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 09:21 UTC by Vladimir Mityukov
Modified: 2012-11-29 20:06 UTC (History)
0 users

See Also:


Attachments
Full dmesg that I've got; Kernel was booted with drm.debug=1 (246.07 KB, text/plain)
2012-11-29 09:21 UTC, Vladimir Mityukov
no flags Details
Xorg log (46.30 KB, text/plain)
2012-11-29 09:22 UTC, Vladimir Mityukov
no flags Details
dmesg -l err,warn (426 bytes, text/plain)
2012-11-29 09:23 UTC, Vladimir Mityukov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Mityukov 2012-11-29 09:21:33 UTC
Created attachment 70778 [details]
Full dmesg that I've got; Kernel was booted with drm.debug=1

I have dual-graphics laptop (AMD Fusion A6 based). Here's the hardware spec:

00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI BeaverCreek [Radeon HD 6520G]
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series]


I can boot into console with KMS enabled, but when I start X Windows (twm, so, not 3D, I believe), I get corrupted screen and the mouse cursor is either locked or unlocked periodically (about 10 seconds for every state). Xorg.log shows "EQ overflow" errors.

Graphics stack:
- DRM: radeon module; Kernel v3.6.5;
- Mesa 9.0.1;
- glamor(git)
- xf86-video-ati(git); built with --enable-glamor; 
P.S.: With EXA or even without explicit definition of "AccelMethod" the problem remains the same. It is the same either with xf86-video-ati 7.0.0 (non-git).

Attaching dmesg and xorg log.
Comment 1 Vladimir Mityukov 2012-11-29 09:22:36 UTC
Created attachment 70779 [details]
Xorg log
Comment 2 Vladimir Mityukov 2012-11-29 09:23:03 UTC
Created attachment 70781 [details]
dmesg -l err,warn
Comment 3 Alex Deucher 2012-11-29 17:22:54 UTC
Looks like a duplicate of bug 56720.  Does disabling colortiling help?

Option "ColorTiling2D" "false"

in the device section of your xorg.conf
Comment 4 Vladimir Mityukov 2012-11-29 19:07:37 UTC
> Does disabling colortiling help?

Definitely. Thank you very much!


I have couple of questions, though (if you have a minute):

1. Do I miss any features (or performance) with the ColorTiling2D option OFF?

2. Is it Ok that I have mentions of EXA in Xorg.0.conf while I have Glamor selected as AccellMethod (I thought Glamor was a _replacement_ for EXA)? Or, is it an indication that I built something wrong?
Comment 5 Alex Deucher 2012-11-29 19:27:12 UTC
(In reply to comment #4)
> > Does disabling colortiling help?
> 
> Definitely. Thank you very much!
> 
> 
> I have couple of questions, though (if you have a minute):
> 
> 1. Do I miss any features (or performance) with the ColorTiling2D option OFF?

Yes, tiling improves performance.

> 
> 2. Is it Ok that I have mentions of EXA in Xorg.0.conf while I have Glamor
> selected as AccellMethod (I thought Glamor was a _replacement_ for EXA)? Or,
> is it an indication that I built something wrong?

Glamor is an alternative for EXA.  If you are still getting EXA, something is wrong with your glamor setup.

*** This bug has been marked as a duplicate of bug 56720 ***
Comment 6 Vladimir Mityukov 2012-11-29 19:53:52 UTC
I'm not sure what I get in the end. Xorg.0.org says it loads Glamor and there are no errors on this topic, than it says it loads EXA.

> egrep -i "exa|glamor" /var/log/Xorg.0.log
> [   470.608] (II) LoadModule: "glamoregl"
> [   470.608] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
> [   470.610] (II) Module glamoregl: vendor="X.Org Foundation"
> [   470.621] (**) RADEON(0): Option "AccelMethod" "glamor"
> [   470.621] (II) Loading sub module "exa"
> [   470.621] (II) LoadModule: "exa"
> [   470.621] (II) Loading /usr/lib/xorg/modules/libexa.so
> [   470.622] (II) Module exa: vendor="X.Org Foundation"
> [   471.019] (II) RADEON(0): Using exact sizes for initial modes
> [   471.019] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
> [   471.020] (II) RADEON(0): Setting EXA maxPitchBytes
> [   471.020] (II) EXA(0): Driver allocated offscreen pixmaps
> [   471.020] (II) EXA(0): Driver registered support for the following operations:

Is there a command I could issue being under X to know it for sure?

Also, is there a Radeon-specific guide for building Glamor? This one(a bit Intel-ish) seem did not work for me:
http://www.freedesktop.org/wiki/Software/Glamor
Comment 7 Alex Deucher 2012-11-29 20:06:41 UTC
(In reply to comment #6)
> 
> Is there a command I could issue being under X to know it for sure?

You should see:

[    22.697] (II) RADEON(0): Use GLAMOR acceleration.
[    22.698] (II) RADEON(0): Acceleration enabled

In your xorg log.

> 
> Also, is there a Radeon-specific guide for building Glamor? This one(a bit
> Intel-ish) seem did not work for me:
> http://www.freedesktop.org/wiki/Software/Glamor

You'll need to build radeon with the --enable-glamor configure option.