Bug 59015 - Steam Beta: Graphical Corruption in certain parts of application tied to "kernel rejected CS" messages
Steam Beta: Graphical Corruption in certain parts of application tied to "ker...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600
9.0
x86-64 (AMD64) Linux (All)
: medium major
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-04 08:48 UTC by Adam Jorgensen
Modified: 2013-01-05 12:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Major Graphical Corruption Occurring in Windows that are not Maximised (424.83 KB, image/png)
2013-01-04 08:48 UTC, Adam Jorgensen
Details
Less corruption when Steam Windows are maximised (447.02 KB, image/png)
2013-01-04 08:50 UTC, Adam Jorgensen
Details
Big Screen Mode works perfectly but is slow (701.79 KB, image/png)
2013-01-04 08:52 UTC, Adam Jorgensen
Details
Current Status as of 04/01/2013 (711.07 KB, image/png)
2013-01-04 08:55 UTC, Adam Jorgensen
Details
X.org log (57.72 KB, text/plain)
2013-01-04 13:57 UTC, Adam Jorgensen
Details
dmesg output (24.93 KB, text/plain)
2013-01-04 13:59 UTC, Adam Jorgensen
Details
glxinfo output (25.23 KB, text/plain)
2013-01-04 13:59 UTC, Adam Jorgensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Jorgensen 2013-01-04 08:48:39 UTC
Created attachment 72495 [details]
Major Graphical Corruption Occurring in Windows that are not Maximised

I am participating in the Steam Linux Beta and am experiencing graphical corruption as captured in the screenshots attached to this ticket.

By starting Steam from the command-line I was able to observe logging messages and noticed that every time a graphical corruption artifact occurs the application outputs the message:

"radeon: The kernel rejected CS, see dmesg for more information."

An examination of dmesg reveals messages as follows:

"
[ 2491.179581] radeon 0000:02:00.0: r600_cs_track_validate_cb invalid tiling 6 for 0 (0x08110668)
[ 2491.179588] radeon 0000:02:00.0: r600_packet3_check:1913 invalid cmd stream 566
[ 2491.179592] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
"

Relevant system info:

1.6ghz Core i7 CPU
8gb DDR3 RAM
Radeon HD 4570 with 512mb DDR2 VRAM using open-source XF86 ATI 7.0.0 drivers
10gb free on root, 30+gb free on home
Kernel 3.6, X.org 1.12.4, KDE 4.9.4 running with OpenGL Compositing
Primary display is 1440x900 laptop LCD, secondary is 24" 1920x1080 LCD
Comment 1 Adam Jorgensen 2013-01-04 08:50:39 UTC
Created attachment 72496 [details]
Less corruption when Steam Windows are maximised

When a window is maximised the corruption is a lot less (Since the latest version of the Steam Linux client is gone, except for drop-down menus and pop-out windows (Like the Friend List) which are ALWAYS corrupt)
Comment 2 Adam Jorgensen 2013-01-04 08:52:56 UTC
Created attachment 72497 [details]
Big Screen Mode works perfectly but is slow

The Big Screen mode seems to work fine, possibly because it functions as a pure OpenGL application?
Comment 3 Adam Jorgensen 2013-01-04 08:55:28 UTC
Created attachment 72498 [details]
Current Status as of 04/01/2013

The Main Steam Window is now displayed perfectly, but drop-down menus and pop-out windows are ALWAYS corrupt, even when maximised.
Comment 4 Andreas Boll 2013-01-04 12:19:43 UTC
Please attach your xorg log and the outputs from dmesg and glxinfo.
Comment 5 Alex Deucher 2013-01-04 13:55:26 UTC
I'm assuming you are using mesa 9.x or newer based on the version info in the bug header.  Can you confirm?  xf86-video-ati 7.0.0 requires mesa 9.x.  Also, if the steam client is a 32-bit application and you are running a 64-bit distro, you will need to make sure your 32-bit 3D driver is up to date.  I suspect you have an out of date 32-bit 3D driver.
Comment 6 Adam Jorgensen 2013-01-04 13:57:44 UTC
Created attachment 72509 [details]
X.org log

My X.org log file
Comment 7 Adam Jorgensen 2013-01-04 13:59:21 UTC
Created attachment 72510 [details]
dmesg output

Output from dmesg after running Steam and triggering corruption
Comment 8 Adam Jorgensen 2013-01-04 13:59:48 UTC
Created attachment 72511 [details]
glxinfo output

Output from glxinfo
Comment 9 Adam Jorgensen 2013-01-04 14:06:22 UTC
(In reply to comment #5)
> I'm assuming you are using mesa 9.x or newer based on the version info in
> the bug header.  Can you confirm?  xf86-video-ati 7.0.0 requires mesa 9.x. 
> Also, if the steam client is a 32-bit application and you are running a
> 64-bit distro, you will need to make sure your 32-bit 3D driver is up to
> date.  I suspect you have an out of date 32-bit 3D driver.

I can confirm that I am using Mesa 9.0.1 in conjunction with xf86-video-ati 7.0.0.

I *thought* I was running Steam as a 64-bit application but based on the lack of an "ubuntu12_64" directory in my  ~/.local/share/Steam directory it seems likely that my Steam installation is actually a 32-bit one.

I am using the latest emul-x86 libs (I'm running Sabayon Linux) but I also have a separate 32-bit chroot for work purposes. I will try updating the chroot environment (Since it's set up with the same distro) and installing Steam their and testing it in that environment...
Comment 10 Adam Jorgensen 2013-01-05 05:35:03 UTC
Okay, so I updated the 32-bit sabayon I use for performing chroot work stuff, installed Steam and then ran the application via the 32-bit chroot and the application works perfectly.

I guess it is thus likely that the sabayon multilibs are currently running a bit behind.
Comment 11 russianneuromancer 2013-01-05 12:51:23 UTC
INVALID then?