Bug 59211 - Acer 19" display AL1917WA requires quirk
Summary: Acer 19" display AL1917WA requires quirk
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-10 19:22 UTC by Esther
Modified: 2019-10-14 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (75.00 KB, text/plain)
2013-01-10 19:22 UTC, Esther
no flags Details
dmesg (58.23 KB, text/plain)
2013-01-10 21:14 UTC, Esther
no flags Details
xorg log (48.80 KB, text/plain)
2013-01-12 21:21 UTC, Esther
no flags Details
xorg conf (492 bytes, text/plain)
2013-01-12 21:26 UTC, Esther
no flags Details
dmesg (58.89 KB, text/plain)
2013-01-12 21:27 UTC, Esther
no flags Details
possible fix (1.14 KB, patch)
2013-01-15 14:41 UTC, Alex Deucher
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Esther 2013-01-10 19:22:58 UTC
Created attachment 72799 [details]
Xorg log

Just recently updated my system from Xubuntu 12.04LTS with fglrx driver to Xubuntu 12.10 with Xorg radeon driver. After bootup screen goes black with monitor reporting "Input not supported". Further investigation shows KMS is trying to default the resolution to 1400 x 1050 which is not supported by the monitor. I can switch to the terminal and run this command to force the correct resolution:

XAUTHORITY=/var/run/lightdm/root/\:0 xrandr --output DVI-0 --mode "1440x900" -d :0.0

Rebooting the system results in the same scenario above. 

System specs
ATI Radeon FireGL RV630 V3600
Acer 19" display AL1917WA w/DVI ouput
Kernal 3.5.0-21-generic
Xorg 1.13.0
Mesa 9.0-0ubuntu1
Xubuntu 12.0
Intel(R) Core(TM)2 Duo CPU     E6550  @ 2.33GHz
Comment 1 Alex Deucher 2013-01-10 19:42:11 UTC
Please attach your dmesg output.  Also, it looks like you have a incorrect preferred mode specified in your xorg.conf:

[   774.834] (II) RADEON(0): Output DVI-0 using monitor section Configured Monitor
[   774.834] (**) RADEON(0): Option "PreferredMode" "1440x990"

Does removing that help?
Comment 2 Esther 2013-01-10 21:14:01 UTC
Created attachment 72809 [details]
dmesg
Comment 3 Alex Deucher 2013-01-10 21:41:09 UTC
Also, I don't know whether it is a bug in your EDID or not, but your monitor claims to support 1440x1050:

[   774.886] (II) RADEON(0): Supported standard timings:
[   774.886] (II) RADEON(0): #0: hsize: 1400  vsize 1050  refresh: 75  vid: 20368
[   774.886] (II) RADEON(0): #1: hsize: 1440  vsize 900  refresh: 75  vid: 3989
[   774.886] (II) RADEON(0): #2: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
[   774.886] (II) RADEON(0): #3: hsize: 1280  vsize 960  refresh: 60  vid: 16513
[   774.886] (II) RADEON(0): #4: hsize: 1280  vsize 800  refresh: 75  vid: 3969
[   774.886] (II) RADEON(0): #5: hsize: 1280  vsize 800  refresh: 60  vid: 129
[   774.886] (II) RADEON(0): #6: hsize: 1152  vsize 921  refresh: 76  vid: 36977
[   774.886] (II) RADEON(0): #7: hsize: 1152  vsize 864  refresh: 75  vid: 20337
Comment 4 Esther 2013-01-11 23:59:41 UTC
removing

[   774.834] (II) RADEON(0): Output DVI-0 using monitor section Configured Monitor
[   774.834] (**) RADEON(0): Option "PreferredMode" "1440x990"

made no difference
Comment 5 Esther 2013-01-12 21:21:39 UTC
Created attachment 72919 [details]
xorg log
Comment 6 Esther 2013-01-12 21:25:20 UTC
After rewriting the xorg.conf file, the system now boots into the Xubuntu login screen. The xorg.conf file forces a 1440x900 resolution. The xorg log still reports that the display is still trying to default to 1400x1050 but that it is a bad resolution. Research on this Acer monitor states that 1440x900 is the preferred or native resolution for the monitor. For whatever reason the fglrx driver had no problems obtaining the correct resolution but the xorg driver does. Attaching the xorg log, dmesg, and xorg.conf files for comparison.
Comment 7 Esther 2013-01-12 21:26:29 UTC
Created attachment 72921 [details]
xorg conf
Comment 8 Esther 2013-01-12 21:27:11 UTC
Created attachment 72922 [details]
dmesg
Comment 9 Alex Deucher 2013-01-12 22:34:29 UTC
Does it work correctly if you remove your xorg.conf altogether?  The monitor is providing the 1400x1050 mode.  If it indeed doesn't support it, we should add a quirk for your monitor to ignore that mode.
Comment 10 Esther 2013-01-13 21:39:26 UTC
Deleting the xorg.conf file causes the system to revert back to the black screen with the "input not supported" message. Once restored, the system booted into the Xubuntu login screen. 1400x1050 is not a supported mode according to the display manual.
Comment 11 Alex Deucher 2013-01-15 14:41:39 UTC
Created attachment 73095 [details] [review]
possible fix

The attached kernel patch should fix the issue.
Comment 12 Martin Peres 2019-10-14 13:20:17 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.