Bug 59217 - Speaker volume is set to 0 when plugging/unplugging headphones
Speaker volume is set to 0 when plugging/unplugging headphones
Status: REOPENED
Product: PulseAudio
Classification: Unclassified
Component: alsa
unspecified
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: pulseaudio-bugs
pulseaudio-bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-10 21:07 UTC by Ignaker
Modified: 2014-03-09 16:28 UTC (History)
4 users (show)

See Also:


Attachments
pacmd ls (19.67 KB, text/plain)
2013-01-10 21:07 UTC, Ignaker
Details
Dell XPS L502X - still not working after the patch. (23.06 KB, text/plain)
2013-01-19 08:26 UTC, Arthur Țițeică
Details
Lenovo X220 pacmd ls (20.96 KB, text/plain)
2014-03-09 14:49 UTC, ValdikSS
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ignaker 2013-01-10 21:07:25 UTC
Created attachment 72808 [details]
pacmd ls

Hello,
sound was ok on my Fujitsu laptop AH530 with Archlinux (x86_64) until I upgraded pulseaudio (and libpulse) to version 3.0.

After upgrading:

1) when pulseaudio starts, the alsa "Speaker" volume is set to zero and I can't hear any sound. If i set again the alsa "Speaker" volume with 'amixer -c0 sset "Speaker" 100%', sound comes back. 
I explicitly tried to set volume to 100% (hearing sound), restarted pulseaudio ('pulseaudio -k', then pulseaudio restarted automatically), verifying that alsa "Speaker" volume was now set to 0.

2) every time I plug or unplug the headphones, alsa "Speaker" volume is set to 0, so, after unplugging the headphones, I can't hear any sound and I must issue again 'amixer -c0 sset "Speaker" 100%' and (again) I explicitly verified alsa "Speaker" volume before and after using output of "amixer -c0".

While headphones are connected, all is working as intended: speakers have volume set to 0 and I can hear sound through the headphones.

With previous version all was ok: some other people on archlinux forum facing same issue solved(?) downgrading to pulseaudio 2.1: I didn't do that because I don't want to mess the bug. 

I don't know exactly which logs, documentation, etc. could be useful: I issued (as root) 'journalctl -b /usr/bin/pulseaudio' but obtained empty output.

I attached output of "pacmd ls".

I can do some experiments if it's necessary.

Sorry for my bad English. Thanks in advance for your valuable time and patience.
Comment 1 Raphael Rochet 2013-01-11 08:34:19 UTC
I suffer from this too.

I have a Toshiba laptop with HDA Intel (Realteck ALC272) chip.
Comment 2 Tanu Kaskinen 2013-01-18 20:30:05 UTC
My guess is that this issue has been fixed by this patch: http://cgit.freedesktop.org/pulseaudio/pulseaudio/commit/?id=a703451811f31abe6302f39675c1e1fdfc1925d6

To verify that, could you try changing /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker-always.conf accordingly?
Comment 3 Raphael Rochet 2013-01-18 20:42:15 UTC
The patch worked for me, now Speaker volume is no more to 0 at boot, neither it is when I unplug the headphones jack.
Comment 4 Tanu Kaskinen 2013-01-18 21:30:44 UTC
Thank you, I'll close this bug.
Comment 5 Ignaker 2013-01-18 21:35:45 UTC
(In reply to comment #4)
> Thank you, I'll close this bug.


Hello Mr. Kaskinen,
I tryed your suggestion and now all works perfectly.

Thanks. Have a nice day.
Comment 6 Arthur Țițeică 2013-01-19 08:24:46 UTC
Still not solved for me after applying the patch. I have the exact same problem as the OP.

I will also attach the output of 'pacmd ls'.

The system is a Dell XPS L502X.

The soundcard is

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
        Subsystem: Dell Device 050e
Comment 7 Arthur Țițeică 2013-01-19 08:26:06 UTC
Created attachment 73277 [details]
Dell XPS L502X - still not working after the patch.
Comment 8 Arthur Țițeică 2013-01-19 15:23:36 UTC
Sorry for the noise. Instead of applying the diff I downloaded analog-output-speaker-always.conf from the git web interface. But I chose the wrong one.

All is fine now.
Comment 9 ValdikSS 2014-03-09 14:46:51 UTC
I have issue with "Speaker" volume. It is set to 0 every boot. IIRC it worked fine with PulseAudio 4 but not with PulseAudio 5.

Lenovo X220, ArchLinux x86_64.
Comment 10 ValdikSS 2014-03-09 14:49:41 UTC
Created attachment 95415 [details]
Lenovo X220 pacmd ls
Comment 11 Tanu Kaskinen 2014-03-09 15:19:54 UTC
You have three ports on the sink: analog-output, analog-output-speaker and analog-output-headphones. The active port is analog-output, which sets the "Speaker" volume to zero. I don't know why analog-output got selected, since analog-output-speaker has higher priority, but you can switch the port with this command:

pactl set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-speaker

If pulseaudio keeps selecting the analog-output port, you're probably suffering from this bug: https://bugs.freedesktop.org/show_bug.cgi?id=74609
Comment 12 Raymond 2014-03-09 16:19:05 UTC
does headphone and dock headphone really support 4.0 ?

for four channels hda codecs with three output pin complexes (headphone , dock headphone and speaker) ,one  volume controls have to shared by two output pins while the other volume control used by one output pin





		output:analog-surround-40: Analog Surround 4.0 Output (priority 700, available: unknown)
		output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (priority 760, available: unknown)
		

		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Built-in Audio Analog Stereo
	sources:
		alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
		alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Built-in Audio Analog Stereo
	ports:
		analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-dock-mic: Dock Microphone (priority 7800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-output: Analog Output (priority 9900, latency offset 0 usec, available: unknown)
			properties:
				
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
Comment 13 ValdikSS 2014-03-09 16:28:54 UTC
(In reply to comment #11)

It is fixed for me after provided command. Thanks a lot!