Bug 59280 - Programs using Clutter crash in brw_update_renderbuffer_surface()
Summary: Programs using Clutter crash in brw_update_renderbuffer_surface()
Status: RESOLVED DUPLICATE of bug 55984
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Chris Wilson
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-12 13:18 UTC by Milan Bouchet-Valat
Modified: 2013-01-12 16:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2013-01-12 13:18:09 UTC
After running out of memory (at least creating some pressure), programs using Clutter such as GNOME Shell, Mutter and GNOME Documents crash on start; once the problem happens it does not disappear. I'm able to reproduce this problem reliably on Fedora 18 with Xorg server 1.13.1, i915 driver 2.20.17, kernel 3.7.1, Mesa 9.0.1 and Clutter 1.12.2.

My GPU is an Ironlake Mobile:
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])

Another person also reported the same crash also with an Ironlake.

Top of the backtrace is:
 #0 brw_update_renderbuffer_surface at brw_wm_surface_state.c:1109
 #1 brw_update_renderbuffer_surfaces at brw_wm_surface_state.c:1205
 #2 brw_upload_state at brw_state_upload.c:498
 #3 brw_try_draw_prims at brw_draw.c:493
 #4 brw_draw_prims at brw_draw.c:589
 #5 vbo_draw_arrays at ../../../src/mesa/vbo/vbo_exec_array.c:645
 #6 _cogl_journal_flush_modelview_and_entries at ./cogl-journal.c:309
 #7 _cogl_journal_flush_vbo_offsets_and_entries at ./cogl-journal.c:647
 #8 _cogl_journal_flush at ./cogl-journal.c:1353
 #9 _cogl_framebuffer_flush_journal at ./cogl-framebuffer.c:632

Full backtrace is at https://bugzilla.redhat.com/attachment.cgi?id=667659
Another one is at: https://bugzilla.redhat.com/attachment.cgi?id=677275

/var/log/messages contains this:
Jan 10 18:54:24 milan kernel: [54093.693625] [drm:i915_hangcheck_hung] *ERROR* H
angcheck timer elapsed... GPU hung
Jan 10 18:54:24 milan kernel: [54093.693634] [drm] capturing error event; look f
or more information in /debug/dri/0/i915_error_state
Jan 10 18:54:26 milan kernel: [54095.530395] [drm:i915_hangcheck_hung] *ERROR* H
angcheck timer elapsed... GPU hung
Jan 10 18:54:26 milan kernel: [54095.530521] [drm:i915_reset] *ERROR* GPU hangin
g too fast, declaring wedged!
Jan 10 18:54:26 milan kernel: [54095.530527] [drm:i915_reset] *ERROR* Failed to 
reset chip.

Contents of /sys/kernel/debug/dri are here:
https://bugzilla.redhat.com/attachment.cgi?id=676703
(please note I suspended the machine between the problem and saving the files, if that's a problem I can get them again)


Downstream bug at: https://bugzilla.redhat.com/show_bug.cgi?id=889663
Comment 1 Daniel Vetter 2013-01-12 13:38:19 UTC
All the debugfs files are empty. The one we need is i915_error_state specifically. Please rehang your machine, grab that file and attach it to this bug.
Comment 2 Chris Wilson 2013-01-12 16:20:27 UTC
99.9% sure...

*** This bug has been marked as a duplicate of bug 55984 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.