Bug 59296 - libGL cannot load r600_dri unless application itself is linked to libstdc++
Summary: libGL cannot load r600_dri unless application itself is linked to libstdc++
Status: RESOLVED DUPLICATE of bug 59282
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-12 20:58 UTC by Chris Rankin
Modified: 2013-01-12 22:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Rankin 2013-01-12 20:58:08 UTC
I have just tried to play WoW using the latest 64 bit Mesa from git, and have noticed that libGL refuses to load the r600_dri object, complaining that:

libGL error: dlopen /usr/local/lib64/dri/r600_dri.so failed (/usr/local/lib64/dri/r600_dri.so: undefined symbol: _ZTVN10__cxxabiv120__si_class_type_infoE)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: Try again with LIBGL_DEBUG=verbose for more details.

The symbol _ZTVN10__cxxabiv120__si_class_type_infoE is from libstdc++, which is not listed as a dynamic dependency of r600_dri. Since wine64 doesn't have a dynamic dependency on libstdc++ either, the dynamic linker does not know how to resolve this symbol.

After I had relinked r600_dri against libstdc++, WoW-64.exe was able to run successfully.
Comment 1 Andreas Boll 2013-01-12 22:41:31 UTC

*** This bug has been marked as a duplicate of bug 59282 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.