Bug 5936 - problems running metacity with GL compositing manager
problems running metacity with GL compositing manager
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300
unspecified
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-18 15:31 UTC by Diego
Modified: 2006-04-29 00:47 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego 2006-02-18 15:31:15 UTC
when i enable the metacity compositing manager i  get the following errors:

~/.xsession-errors
drmRadeonCmdBuffer: -22 (exiting)

/var/log/kernel
Feb 18 05:28:02 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:02 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:02 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:04 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:04 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:04 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:05 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:05 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:05 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:06 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:06 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:06 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:10 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:10 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:10 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:12 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:12 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:12 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:13 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:13 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:13 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:14 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:14 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:14 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:17 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:17 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:17 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:18 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:18 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:18 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed
Feb 18 05:28:20 calisto kernel: [drm:r300_emit_raw_packet3] *ERROR* Unknown
packet3 header (0xc0059b00)
Feb 18 05:28:20 calisto kernel: [drm:r300_emit_packet3] *ERROR*
r300_emit_raw_packet3 failed
Feb 18 05:28:20 calisto kernel: [drm:r300_do_cp_cmdbuf] *ERROR*
r300_emit_packet3 failed

The metacity compositing manager is using the new extension with BindImageEXT
and ReleaseImageEXT.
Comment 1 Diego 2006-02-18 15:32:34 UTC
BTW i almost forget it. I'm using a
0000:01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon
Mobility M300]
Comment 2 Dave Airlie 2006-02-18 15:35:25 UTC
should be fixed in DRM CVS now...
Comment 3 Diego 2006-02-19 00:12:04 UTC
Ok, this fixed the errors and the compositing manager works (ie doesn't crash)
but everything that i see is white except for the drop shadows around the
windows which are shadows between black and white
Comment 4 Kristian Høgsberg 2006-03-07 14:44:49 UTC
This can be a number of problems, either the tfp extension isn't supported or detected correctly, there 
might be a problem with textures exceeding maximum texture size or the version of metacity you're 
running creates a direct gl context (it needs an indirect context, set LIBGL_ALWAYS_INDIRECT=1 to 
force an indirect context).

In any case, all this is in heavy development at the moment, so do try a new checkout, but don't expect 
too much :)
Comment 5 Dave Airlie 2006-04-29 17:47:46 UTC
the original bug is fixed the other bug is a duplicate of 5999