Bug 59536 - [ILK] Low framerate when looking through a Portal in Portal; low framerate generally in Portal 2.
Summary: [ILK] Low framerate when looking through a Portal in Portal; low framerate ge...
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 9.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-17 23:47 UTC by Murray Colpman
Modified: 2017-02-10 22:38 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Murray Colpman 2013-01-17 23:47:49 UTC
I don't know if this is expected for these GPUs, but from talks on #intel-gfx, it does seem like there is something out of the ordinary, and I was told to file a bug. When playing Portal under wine on my i5 M520 with its on-die GPU on a Thinkpad T410, the original Portal drops to a low framerate whenever a Portal is looked through. There is generally a low framerate in Portal 2, which does indeed get lower still when a Portal is looked through. It's a very dramatic difference; without a Portal on the screen, the game usually runs at an acceptable framerate; with a Portal anywhere on the screen, it slows to around 5-10fps. I've disabled GLSL in wine due to another bug (which I'm about to file), but even with it enabled, the framerate difference is about the same. Kernel 3.6.11-gentoo. A longer discussion that I had about the issue has been previously pastebin'd here: http://pastebin.com/cckwXQVC (in case I missed anything from this description).
Comment 1 Matt Turner 2016-11-03 02:40:44 UTC
Sorry no one ever investigated your bug.

Please test a new version of Mesa (12 or 13) and mark as REOPENED
if you can reproduce and RESOLVED/* if you cannot reproduce. Lots of performance improvements have gone into Mesa and the i965 driver since 9.0.

You should also try setting INTEL_DEBUG=perf and see if it tells us anything interesting.
Comment 2 Annie 2017-02-10 22:38:26 UTC
Dear Reporter,

This Mesa bug has been in the "NEEDINFO" status for over 60 days. I am closing this bug based on lack of response but feel free to reopen if resolution is still needed. Please ensure you're supplying the correct information as requested.

Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.