Bug 59636 - vertical quote marks not displayed in computer code representation
vertical quote marks not displayed in computer code representation
Status: RESOLVED NOTOURBUG
Product: poppler
Classification: Unclassified
Component: general
unspecified
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: poppler-bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-20 20:14 UTC by Paul Johnson
Modified: 2013-01-20 23:13 UTC (History)
0 users

See Also:


Attachments
a pdf in which the vertical quote mark is invisible when rendered (175.52 KB, text/plain)
2013-01-20 20:14 UTC, Paul Johnson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Johnson 2013-01-20 20:14:23 UTC
Created attachment 73342 [details]
a pdf in which the vertical quote mark is invisible when rendered

Documents that use type writer font with vertical single quote are IMPOSSIBLE to read in Evince because the single quotes are invisible. I mean the symbol ', not the grave or slanted quote mark.  That symbol does show in Adobe Acrobat reader, so I know it is there, but Evince viewer doesn't show it. 

This is happening on Debian Wheezy Beta 4. That supplies poppler libraries 0.18.4 and Evince version  3.4.0

I tried to report this to the Evince team, but they send me here, claiming that rendering is done by Poppler.

Why this is important?  Documents about computer programming that use the single quote in code examples are impossible to read.  
I'm attaching one example PDF.  To see the problem, go to page 7, in the shaded code example in section 2.8, the function has a single quote in it

> cppFunction('
int fibonacci(const int x) {

and one at the end. 

Incredibly, I just cut and pasted that from Evince and it shows the ' is really there, it just does not show on the screen.

What else do I know about this?  I know the troublesome documents are created by LaTeX, and I suspect that the LaTeX "ae" package is used for the type writer fonts.  I also know that the pdf file does have the fonts embedded. 

Acrobat does show this symbol. 

On a  lark, I have also installed some other pdf viewers. Okular does show it. As far as I can see, that does not use Poppler.

I was advised to test xpdf as well. That one works as well. That's confusing. Doesn't xpdf depend on libpoppler. So if the symbol shows in xpdf, does that mean we should be looking for the bug in Evince, not Poppler? 

To me, this is major major, a show stopper, if I am complaining to the wrong people (again), please let me know, I will complain elsewhere :)
Comment 1 Jose Aliste 2013-01-20 20:20:28 UTC
works for me on evince 3.6 with poppler 0.20
Comment 2 Jose Aliste 2013-01-20 20:42:40 UTC
I forgot to add. Okular USES poppler while xpdf DOES NOT. But poppler has a SplashBackend and a Cairo Backend. The Splash backend is what okular uses  while the cairo backend is used by evince. So rendering errors that happen only on evince are usually bugs on the cairo backend.
Comment 3 Albert Astals Cid 2013-01-20 23:04:53 UTC
Not a major bug since it's not killing babies
Comment 4 Albert Astals Cid 2013-01-20 23:13:45 UTC
I can reproduce the bug with
 * poppler 0.20.4 and cairo 1.12.2
 * poppler 0.22.0 and cairo 1.12.2

I can not reproduce the bug with
 * poppler 0.20.5 and cairo 1.12.8
 * poppler 0.22.0 and cairo 1.12.8

So it seems to be a bug in cairo that has already been fixed. Paul if you have one of the combos where we can not reproduce the bug and it still fails for you please reopen the bug.