Bug 59851 - AC_ARG_WITH misusage leading to mesa configure failure
Summary: AC_ARG_WITH misusage leading to mesa configure failure
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: All All
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
: 59994 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-25 14:35 UTC by Quentin "Sardem FF7" Glidic
Modified: 2013-02-01 22:48 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Patch to fix mesa configure (1.47 KB, text/plain)
2013-01-25 14:35 UTC, Quentin "Sardem FF7" Glidic
Details
Patch to fix mesa configure (1.54 KB, patch)
2013-01-31 13:05 UTC, Quentin "Sardem FF7" Glidic
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Quentin "Sardem FF7" Glidic 2013-01-25 14:35:47 UTC
Created attachment 73648 [details]
Patch to fix mesa configure

Copy of the commit message:

The third argument of AC_ARG_WITH is evaluated for any provided value,
not only on --with-, so it must not force-enable the feature
Also, setting $with_llvm_shared_libs in the opencl check was overriding
the user switch
Comment 1 Johannes Obermayr 2013-01-29 21:24:06 UTC
*** Bug 59994 has been marked as a duplicate of this bug. ***
Comment 2 Quentin "Sardem FF7" Glidic 2013-01-31 13:05:48 UTC
Created attachment 73992 [details] [review]
Patch to fix mesa configure

Patch fixed and with a different logic. Now force-enable LLVM shared libraries in a post-check, with a warning for the user.
Comment 3 Tom Stellard 2013-01-31 14:10:06 UTC
(In reply to comment #2)
> Created attachment 73992 [details] [review] [review]
> Patch to fix mesa configure
> 
> Patch fixed and with a different logic. Now force-enable LLVM shared
> libraries in a post-check, with a warning for the user.

Thanks for the patch, it looks good to me, but I need to test it out on a few configurations before I push it.
Comment 4 Tom Stellard 2013-02-01 22:48:03 UTC
Fixed by commit 	1e857130f06d7db0c77d73b6356528f4792967ff 

Thanks for the patch!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.