Bug 59930 - Partially transparent objects in Neverwinter Nights Linux version
Summary: Partially transparent objects in Neverwinter Nights Linux version
Status: RESOLVED DUPLICATE of bug 13728
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 9.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-27 13:09 UTC by Vasyl Demin
Modified: 2016-11-03 02:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot showing the problem (749.52 KB, image/png)
2013-01-27 13:09 UTC, Vasyl Demin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasyl Demin 2013-01-27 13:09:46 UTC
Created attachment 73728 [details]
Screenshot showing the problem

I have exactly same problem as described here:
https://bugs.freedesktop.org/show_bug.cgi?id=13728

Overall NWN seems to be running OK, however many objects including characters look like dithering, partially transparent mix of pixels. Such objects include chests, tables, doors and all characters. When "environmental mapping on creatures" feature is turned on, it resolves the issue for characters, however the rest remains the same.

My notebook is Lenovo Thinkpad T510 with integrated intel video:
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

OS: Arch Linux x86_64
kernel: 3.7.4
xf86-video-intel: 2.20.19
mesa: 9.0.2

I've tried to downgrade Mesa and here is the results of experiments:
7.11.2  - NWN works perfectly
8.0.0 - 8.0.3  - I can't even load a saved game (don't know why)
8.0.4 - 9.0.2  - NWN works but has this bug
Comment 1 Matt Turner 2016-11-03 02:52:14 UTC
Wrong component meant no one saw this bug.

*** This bug has been marked as a duplicate of bug 13728 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.