Bug 60503 - [r300g] Unigine Heaven 3.0: all objects are black
Summary: [r300g] Unigine Heaven 3.0: all objects are black
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL: http://unigine.com/products/heaven/do...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 16:49 UTC by Pavel Ondračka
Modified: 2013-04-12 16:43 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
RADEON_DEBUG=fp log (267.29 KB, application/x-bzip)
2013-02-09 08:49 UTC, Pavel Ondračka
Details
Possible fix (1.12 KB, patch)
2013-02-10 00:17 UTC, Tom Stellard
Details | Splinter Review
RADEON_DEBUG=fp log with patch applied (251.30 KB, application/x-bzip)
2013-02-10 00:46 UTC, Pavel Ondračka
Details
Fix v2 (1.30 KB, text/plain)
2013-02-10 05:17 UTC, Tom Stellard
Details
RADEON_DEBUG=fp log with patch v2 applied (315.52 KB, application/x-bzip)
2013-02-10 11:03 UTC, Pavel Ondračka
Details
Possible fix v3 (1.29 KB, patch)
2013-03-20 02:39 UTC, Tom Stellard
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Ondračka 2013-02-08 16:49:24 UTC
All object in the 3.0 Heaven version are completely black... this seems to be the cause:
r300 FP: Compiler Error:
Rewrite of inst 4 failed Can't allocate source for Inst 36 src_type=1 new_index=1 new_mask=4
Using a dummy shader instead.

Full RADEON_DEBUG=fp log attached.

This may be a hardware limitation, however Heaven 2.1 version works fine, so maybe just a bug in the shader compiler.

GPU: RV530
Mesa: b681ed6ac970e061e9dbe7309bb69b3a947ae62d
Kernel: 3.6.11-1.fc17.i686
Comment 1 Pavel Ondračka 2013-02-09 08:49:44 UTC
Created attachment 74476 [details]
RADEON_DEBUG=fp log

I actually forgot to attach the log.
Comment 2 Tom Stellard 2013-02-10 00:17:39 UTC
Created attachment 74515 [details] [review]
Possible fix

Does this patch fix the issue?
Comment 3 Pavel Ondračka 2013-02-10 00:20:03 UTC
BTW this works fine with RADEON_DEBUG=noopt.
Comment 4 Pavel Ondračka 2013-02-10 00:30:08 UTC
(In reply to comment #2)
> Created attachment 74515 [details] [review] [review]
> Possible fix
> 
> Does this patch fix the issue?

No it doesn't.
Comment 5 Tom Stellard 2013-02-10 00:37:15 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Created attachment 74515 [details] [review] [review] [review]
> > Possible fix
> > 
> > Does this patch fix the issue?
> 
> No it doesn't.

Can you post the RADEON_DEBUG=fp dump with the patch applied?
Comment 6 Pavel Ondračka 2013-02-10 00:46:13 UTC
Created attachment 74516 [details]
RADEON_DEBUG=fp log with patch applied
Comment 7 Tom Stellard 2013-02-10 05:17:13 UTC
Created attachment 74520 [details]
Fix v2

This should fix the problem, can you verify?
Comment 8 Pavel Ondračka 2013-02-10 11:03:39 UTC
Created attachment 74525 [details]
RADEON_DEBUG=fp log with patch v2 applied

(In reply to comment #7)
> Created attachment 74520 [details]
> Fix v2
> 
> This should fix the problem, can you verify?

Sorry, it still isn't fixed. New log attached.
Comment 9 Tom Stellard 2013-02-12 15:47:01 UTC
(In reply to comment #8)
> Created attachment 74525 [details]
> RADEON_DEBUG=fp log with patch v2 applied
> 
> (In reply to comment #7)
> > Created attachment 74520 [details]
> > Fix v2
> > 
> > This should fix the problem, can you verify?
> 
> Sorry, it still isn't fixed. New log attached.

Ok, maybe I made a mistake posting the patch:  Can you apply all six patches from:http://lists.freedesktop.org/archives/mesa-dev/2013-February/034357.html

After you apply the patches, run make check from src/gallium/drivers/r300 and make sure it passes and then re-test Heaven.
Comment 10 Pavel Ondračka 2013-02-12 17:22:35 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Created attachment 74525 [details]
> > RADEON_DEBUG=fp log with patch v2 applied
> > 
> > (In reply to comment #7)
> > > Created attachment 74520 [details]
> > > Fix v2
> > > 
> > > This should fix the problem, can you verify?
> > 
> > Sorry, it still isn't fixed. New log attached.
> 
> Ok, maybe I made a mistake posting the patch:  Can you apply all six patches
> from:http://lists.freedesktop.org/archives/mesa-dev/2013-February/034357.html
> 
> After you apply the patches, run make check from src/gallium/drivers/r300
> and make sure it passes and then re-test Heaven.

OK, with whole patch series applied the tests passes, however Heaven is still black.
Comment 11 Tom Stellard 2013-03-20 02:39:26 UTC
Created attachment 76797 [details] [review]
Possible fix v3

Does this patch help?
Comment 12 Pavel Ondračka 2013-03-20 15:19:34 UTC
(In reply to comment #11)
> Created attachment 76797 [details] [review] [review]
> Possible fix v3
> 
> Does this patch help?

Yes, this one fixes it.
Comment 13 Pavel Ondračka 2013-03-20 20:56:38 UTC
BTW i did a quick tests piglit run with your patch on my RV530 with no regressions (no fixes either except 2 tests in EXT_framebuffer_multisample group, however those seems to be fairly random... )
Comment 14 Tom Stellard 2013-04-12 16:43:53 UTC
Fixed in commit c6a86fb5639977f37a1403012669cdee86bbd89f

Thanks for your help with testing!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.