Bug 60511 - (offset-bug-in-i915) [ivb] help with offset bug in lvds
(offset-bug-in-i915)
[ivb] help with offset bug in lvds
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
x86-64 (AMD64) Linux (All)
: low minor
Assigned To: Intel GFX Bugs mailing list
Intel GFX Bugs mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 18:54 UTC by gustafba
Modified: 2013-02-09 21:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gustafba 2013-02-08 18:54:25 UTC
Hello all,

I have been searching for the bug in the intel graphix i915 on the
internet. 
Where LVDS display has offset to left. When I use external monitors, there is no problem. The case is only when I enable i915 modeset=1 , then there is the offset. Without i915 there is no offset but I cant use external monitors.
And I have found this similar/same bug:
"LVDS fixed-mode regression from 219adae1"
I have Intel HD 4000 Core i5, dell latitude e6230

https://patchwork.kernel.org/patch/309832/
http://www.kerneltrap.org/mailarchive/linux-kernel/2010/11/8/4642488

I've tried to apply patch from these but without any success.

# uname -a
Linux 3.2.6 #1 SMP Fri Feb 17 10:34:20 EST 2012 x86_64 GNU/Linux

I put Low priority as I can use external monitor but I would like to use my laptop monitor too. Also I dont want to update kernel or upgrade distro. I have Ubuntu 10.04 LTS but with kernel 3.2.6

Please could someone give me some advice please?

Best Regards
--Gustaf
Comment 1 Daniel Vetter 2013-02-09 12:05:02 UTC
Please retest with latest kernels, preferrably 3.8-rc series. Just to check that it's not fixed already.

If things are still broken for you, we can then gather debug information.
Comment 2 gustafba 2013-02-09 15:31:37 UTC
(In reply to comment #1)
> Please retest with latest kernels, preferrably 3.8-rc series. Just to check
> that it's not fixed already.
> 
> If things are still broken for you, we can then gather debug information.

Hi all,

indeed there is bug with drm on the kernel 3.2.6 I've installed 3.2.15 and it works OK!

--Thank you

I didnt install newer kernel as it requires libc6 2.14 and on older kernel its 2.11 and I m afraid installing libc6 2.14 if it wont break old kernels.

Can I do something to diff the drm changes between 3.2.6 and 3.2.15 because I m also afraid of breaking dependencies because of newer kernel.

Due to that it is really low priority now but I would really be happy if someone who is interested could help me out.

--Gustaf
Comment 3 Daniel Vetter 2013-02-09 20:01:32 UTC
For upgrading the kernel: That shouldn't ever require a userspace upgrade since the kernel won't break old userspace (otherwise it's a high-prio bug). If your distro doesn't let you do that, you need to yell at them ;-)
Comment 4 gustafba 2013-02-09 21:36:50 UTC
(In reply to comment #3)
> For upgrading the kernel: That shouldn't ever require a userspace upgrade
> since the kernel won't break old userspace (otherwise it's a high-prio bug).
> If your distro doesn't let you do that, you need to yell at them ;-)

Hi,

I am working as Linux/Unix Server admin and have had issues in the past when kernel upgrade has broken the application functionality. And since I am using Ubuntu 10.04 LTS with kernel 3.2.15 now:) I will go for 3.8.rc7.

Anyway thank you for your help.
I think updating of kernel for me was like going to dentist. I was too scared in the beginning and after the check i've figured out it was piece of cake and actually helped alot. ;)
case solved.

--Gustaf