Bug 606 - [XKB] Error activating XKB configuration.
Summary: [XKB] Error activating XKB configuration.
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xkbcomp (show other bugs)
Version: 6.7.0
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: movetoxkc
: 655 1971 1972 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-07 09:06 UTC by Greg Toombs
Modified: 2008-07-11 14:22 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Toombs 2004-05-07 09:06:50 UTC
I received this error upon login. Unfortunately I do not know how to provide the
information that the error message requested.


Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
Comment 1 Greg Toombs 2004-05-07 09:09:24 UTC
xprop -root | grep XKB

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

Does not output anything.
Comment 2 Alan Coopersmith 2004-05-30 05:03:16 UTC
This may be a bug in libxklavier actually, where it hardcoded for xfree86.
Comment 3 Alan Coopersmith 2004-05-30 05:05:18 UTC
Whoops - accidentally submitted halfway through what I was typing.

As I was saying, this might be a libxklavier bug - see the comments in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120858

It may help if you make a symlink from xfree86.lst -> xorg.lst.
Comment 4 Stéphane Loeuillet 2004-06-07 02:28:03 UTC
alan, you mean it is a dupe of bug #477 ? (also old libxklavier's fault)

libxklavier is not part of xorg, both should be closed (RESOLVED/NOTOURBUG)
Comment 5 Jerome Pinot 2004-06-19 04:18:38 UTC
I got the same problem on my box when I want to select a Korean keyboard map.

On the console:

(EE) Error loading keymap /var/tmp/server-0.xkm
Error loading new keyboard description
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Can't find file "pc/ko" for symbols include
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server

xprop -root | grep XKB

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "nodeadkeys", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

 layouts = [us,ko]
 model = pc105
 overrideSettings = false
 options = []

Problem happens with Xorg 6.7.0 and XFree86 4.4.0
It doesn't depends of wm (Gnome 2.6.1 and KDE 3.2.3 failed to load the map)
Yeah, the pc/ko file doesn't exist but it didn't exist on XFree86 4.3.0 and it
was not a problem.

IMHO:
Before Xfree86 4.4/Xorg 6.7.0, there was no direct korean mapping included in X,
I mean I have to use an Input Method and the one of Gnome 2.4 was pretty nice
for this. On any gnome/Gtk application I could use
right_click->Input_Methods->Hangul
But there was no mapping accessible from KDE.

With Xorg, it seems there is support for korean. KDE suggests korean mapping,
Gnome too via the keyboard property.
The first problem is it can not be used without getting the bug described here.
The main problem is there is no more hangul input method in gnome application
and I suspect it comes from Xorg too.

Actually, I have no more way to input korean except using specific applications.

I wonder if these problems are somewhere connected, the bug from Xorg and the
input method support from Gnome.

I already tried all the fixes suggested in some forums/bugzilla (RedHat,
Dropline, Linuxquestions...) and nothing work.

If there is a xkb/symbols/pc/ko somewhere, please say me. I'm in trouble to
maintain my french-korean website.

Regards,

PS: Hangul is the name of the korean alphabet.
Comment 6 sangu 2004-09-22 21:42:22 UTC
Please see: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125365

This problem happens in gnome-keyboard-properties, too.
Comment 7 Danie Wessels 2004-10-22 00:28:21 UTC
Now in Fedora Core 2 (Upgraded from RH9) with my 
A4TECH keyboard, "Model: KBS-720" I get (when entering X):

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
" which gave:
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us_intl", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us_intl", "", ""

And "

- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
" which gave:
 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
"

By the way: It now showed: ¨ instead of " in the text above when I copied this 
text from the error file I wrote in Kedit and pasted it here from a VIM window 
from Win2k. Otherwise keyboard input seems ok(?) I did not have this problem 
with RedHat 9.

This report seem to be related to bug report 655
Comment 8 Danie Wessels 2004-10-22 00:38:48 UTC
Sorry, I forgot to add this as well (in my case):

Every time I when I type one of these 5 keys: ´, ¨, `, ~ or ^, this key and 
the next key stroke gets ignored, unles I type the same key again, then that 
key gets recognised once. 

PS. These keys should be ['], ["], [`], [~] and [^].
Is my hardware maybe unsupported now? Wrong keymap? 
(I am think (not sure) that it worked in RH9) 
How can I fix it (link to X keyboard HOWTO perhaps)?
Comment 9 Danie Wessels 2004-11-02 03:09:58 UTC
From A4Tech.com.cn:
"....
Sorry ,currently, all our keyboard drivers are totally incompatible Linux ,we 
apologize to be unable to provide you the keyboard driver for your Linux 
professional .
..."
Thus: For my problem I now need to know HOW-TO add these keys and register this 
model to the xkeymap (or what?).
Comment 10 Alexander Gottwald 2004-11-30 05:10:29 UTC
*** Bug 1972 has been marked as a duplicate of this bug. ***
Comment 11 Alexander Gottwald 2004-11-30 05:11:25 UTC
*** Bug 1971 has been marked as a duplicate of this bug. ***
Comment 12 Alan 2004-12-12 10:38:19 UTC
I have a similar problem...

I have just built a new box from Gentoo stage1

Kernel version is 2.6.9-gentoo-r9n
udev
xorg version is 6.8.0 revision r3-0.2.2.1
Gnome is 2.8

I have build it with a gnome-light build as I didn't want ephiphany/evolution
combinations and they require Mozilla as a dependency.

The Output requested on the dialogue box is 

bocutta@Jaguar bocutta $ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "gb", "gb", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "gb", "gb", ""

bocutta@Jaguar bocutta $ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [gb  gb]
 model = pc105
 overrideSettings = false
 options = []
 update_handlers = []
Comment 13 Donnie Berkholz 2004-12-12 12:41:04 UTC
If you're using Gentoo, please check whether /usr/X11R6/lib/X11/xkb/xkbcomp has
a size of zero. That's a bug in one of the lesser-used updating tools,
dispatch-conf.
Comment 14 Alan Coopersmith 2005-03-20 09:04:54 UTC
*** Bug 655 has been marked as a duplicate of this bug. ***
Comment 15 Sergey V. Udaltsov 2006-04-05 07:30:38 UTC
It should be ok now, with the latest xkeyboard-config/xorg combination. Is it?
Comment 16 Mark Deepwell 2006-04-19 08:55:27 UTC
I get this same error after I upgraded my gentoo box from xorg 6.8 to 7.0.
Everytime I log into Gnome I get the nice error message. Here's the output:

# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us]
 model = microsoft
 overrideSettings = false
 options = []

As for Donnie Berkholz's idea, /usr/X11R6/lib/X11/xkb/xkbcomp does not exist.
This folder is not even created: /usr/X11R6/lib/X11/xkb. If there is a bug in
dispatch-conf, how do I manually fix this?
Comment 17 Mathieu Avoine 2006-04-28 09:41:04 UTC
I get the same error everytime I boot.
I am running Ubuntu 5.10 (breezy). Unfortunately I don't know what I did that
made the issue appear. Probably played with the keyboard configuration. Anyway
here's the info that the error box recommended to append:

xprop -root | grep XKB

_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc101", "ca", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc101", "ca", "", ""


gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

 layouts = [ca  fr,ca   fr-legacy,us,ca_enhanced]
 model = itouch
 options = [grp grp:alts_toggle]
 overrideSettings = true
Comment 18 Stéphane Loeuillet 2006-04-28 17:12:21 UTC
Mathieu (comment #17) :

xfree86 => xorg on both lines
if you're using xorg (6.8 ...), if you're using a good old xfree, it's something
else.
Comment 19 Erik Andren 2006-06-28 12:16:32 UTC
Bug poster, is this still an issue using a current version of xorg?
Comment 20 thomas 2006-07-09 19:04:27 UTC
I've had this same issue for a long time, but switched to a generic keyboard
model to alleviate it.  I don't remember always having this issue, and I do
recall it happening around the same time I discovered dispatch-conf.  The file

/usr/share/X11/xkb/xkbcomp

has a size of zero, as was mentioned earlier.. how can I fix this?
Comment 21 thomas 2006-07-09 19:16:27 UTC
(In reply to comment #20)
> I've had this same issue for a long time, but switched to a generic keyboard
> model to alleviate it.  I don't remember always having this issue, and I do
> recall it happening around the same time I discovered dispatch-conf.  The file
> 
> /usr/share/X11/xkb/xkbcomp
> 
> has a size of zero, as was mentioned earlier.. how can I fix this?

I created a symbolic link from:

/usr/X11R6/lib/X11/xkb/xkbcomp

to:

/usr/bin/xkbcomp

I had to create the directory /usr/X11R6/lib/X11/xkb/ first.

This did not solve the bug.  I'm on gentoo.
Comment 22 Mark Deepwell 2006-08-29 17:28:20 UTC
Yes, this problem is still very relevant. I just updated to xorg 7.1.

X server version data:
The X.Org Foundation
70101000

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

$  gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us]
 model = microsoftinet
 overrideSettings = false
 options = []

I can provide any information needed.
Comment 23 James C. Georgas 2006-12-15 09:35:36 UTC
I'm still getting this error too. I'm using xorg-server from git. 7.0 didn't
have this issue.
Comment 24 Danie Wessels 2007-01-02 03:43:30 UTC
(In reply to comment #9)
> From A4Tech.com.cn:
> "....
> Sorry ,currently, all our keyboard drivers are totally incompatible Linux ,we 
> apologize to be unable to provide you the keyboard driver for your Linux 
> professional .
> ..."
> Thus: For my problem I now need to know HOW-TO add these keys and register this 
> model to the xkeymap (or what?).
No more a problem with Fedora Core 6. Also I did not understand the working of
deadkeys. For me, it is now resolved.
Comment 25 piotrek 2007-01-02 11:15:01 UTC
Hi I have exactly the same error in my Gentoo 2006.1 probably after upgrade
xorg.server
This is link to bug on gentoo bugzilla
https://bugs.gentoo.org/show_bug.cgi?id=156307 pasted by me and discussion about
it on gentoo forum http://forums.gentoo.org/viewtopic-t-519428-highlight-.html
this bug is similar to this
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125365 so i am writing here.
I am using KDE 3.5.5 xorg 7.1 and Nvidia drivers.
If you need more info feel free to write to me.
Comment 26 Benjamin Close 2008-01-11 02:37:54 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.