Bug 60797 - 1px lines in octave plot aliased to 0
Summary: 1px lines in octave plot aliased to 0
Status: RESOLVED DUPLICATE of bug 28832
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 9.0
Hardware: Other All
: medium normal
Assignee: marius predut
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-13 15:13 UTC by Cedric Sodhi
Modified: 2015-05-06 19:10 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
apitrace output (819.94 KB, text/plain)
2014-03-12 13:27 UTC, Samuel Iglesias
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cedric Sodhi 2013-02-13 15:13:40 UTC
With Octave 3.6.3

OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL version string: 3.0 Mesa 9.0.1
x11-drivers/xf86-video-intel-2.21.2
8086:0106 (rev 09) 

gt1

also on

gm45

Start octave, perform as shown here [1]:

graphics_toolkit( "fltk" )
tx = ty = linspace (-8, 8, 41)';
[xx, yy] = meshgrid (tx, ty);
r = sqrt (xx .^ 2 + yy .^ 2) + eps;
tz = sin (r) ./ r;
mesh (tx, ty, tz);

The resulting plot doesn't look like in [1] but instead the thin gridlines vanish due to aliasing. LIBGL_ALWAYS_SOFTWARE=1 does not show such behaviour.

[1] http://www.gnu.org/software/octave/doc/interpreter/Three_002dDimensional-Plots.html#Three_002dDimensional-Plots
Comment 1 Samuel Iglesias 2014-03-12 13:27:17 UTC
Created attachment 95661 [details]
apitrace output
Comment 2 Samuel Iglesias 2014-03-12 13:33:42 UTC
I can reproduce this bug with Octave 3.8.0 and latest version of mesa:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.2.0-devel (git-952fda4)
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)


As Cedric says, if LIBGL_ALWAYS_SOFTWARE=1 is exported then the plot is rendered fine.
Comment 3 Samuel Iglesias 2014-03-17 09:59:08 UTC
It is a duplicate of bug 28832 but, at this case, octave is showing the AA line width bug.

*** This bug has been marked as a duplicate of bug 28832 ***
Comment 4 marius predut 2015-05-06 19:05:45 UTC
The patches that fix this bug is up-streamed


bug/show.html.tmpl processed on Jan 19, 2017 at 21:15:58.
(provided by the Example extension).