Bug 61123 - spice-guest-tools-0.100.exe does not install the QXL driver on Vista
Summary: spice-guest-tools-0.100.exe does not install the QXL driver on Vista
Status: RESOLVED MOVED
Alias: None
Product: Spice
Classification: Unclassified
Component: win32 guest-tools (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Spice Bug List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 15:11 UTC by Francois Gouget
Modified: 2018-06-05 14:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
missing qxl files (47.43 KB, image/png)
2015-05-07 09:09 UTC, Francois Gouget
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Gouget 2013-02-19 15:11:43 UTC
Running spice-guest-tools-0.3.exe in a QEmu/KVM guest VM normally installs the QXL graphics driver alongside the Virtio drivers. However on Windows Vista and presumably Windows 2003, Windows 2008 and Windows 2008r2 this is not the case.

Looking at the installed files I see that only the drivers/winxp and drivers/win7 directories have QXL drivers which is probably the first-level reason for this. Note that both the Windows XP and Windows 7 QXL drivers install successfully on Windows Vista so that provides a workaround.

Using the QXL driver on Vista greatly improves the mouse handling. It does have an alpha blending issue which is visible in the Desktop Gadgets area though.
Comment 1 Francois Gouget 2013-02-19 16:48:10 UTC
Some extra informaion:
 * 32-bit Windows Vista straight from CD, no windows updates.

 * For more details about the transparency issue see bug 61124.
   https://bugs.freedesktop.org/show_bug.cgi?id=61124
Comment 2 Christophe Fergeau 2015-05-01 11:27:55 UTC
Is this still an issue with the newest spice-guest-tools release (0.100)? http://www.spice-space.org/download/windows/spice-guest-tools/spice-guest-tools-0.100.exe
Comment 3 Francois Gouget 2015-05-07 09:09:45 UTC
Created attachment 115620 [details]
missing qxl files

Yes, this issue is still present with the spice-guest-tools 0.100 release. During installation I get prompts asking whether to install the unsigned drivers (Virtio-Serial, Virtio Balloon, Red Hat Virtio SCSI, Red Hat Virtio Ethernet). The next installer steps flash too quickly for me to be able to read them and I get to the 'Finish' button with no QXL driver.

A workaround is to then install the QXL driver manually by manually browsing and picking the Windows XP one.

As before, looking at the content of c:\Program Files\SPICE Guest Tools\drivers I see that there is no qxl.* file in the vista, win2k3, win2k8 directories (also apparently there is no 32 bit driver for win2k8r2, and no 64 bit driver for winxp.

Note that vdagent.exe does get installed and runs.
Comment 4 Francois Gouget 2015-05-07 09:10:30 UTC
Reopening as the issue is still present.
Comment 5 GitLab Migration User 2018-06-05 14:14:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/spice/spice-nsis/issues/1.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.