Bug 61292 - Stop having a property name that is the same as a method name
Summary: Stop having a property name that is the same as a method name
Alias: None
Product: accountsservice
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Matthias Clasen
QA Contact:
Depends on:
Reported: 2013-02-22 16:58 UTC by Giovanni Campagna
Modified: 2018-08-07 09:31 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Giovanni Campagna 2013-02-22 16:58:49 UTC
act_user_is_loaded() and ActUser:is-loaded shadow each other, and this confuses language bindings.

In particular, this is one of those cases where https://bugzilla.gnome.org/show_bug.cgi?id=690450 causes a regression.

(I don't know if you follow the GNOME release, but in that case, I guess this is matter for the next cycle, because it involves an API change)
Comment 1 Matthias Clasen 2013-04-03 17:39:22 UTC
Can we use annotations to resolve the confusion ?
Comment 2 Giovanni Campagna 2013-04-10 15:05:01 UTC
Annotations cannot rename properties. We can rename act_user_is_loaded() to something else, but currently gobject-introspection requires that the new name already exists (ie if we go for act_user_get_is_loaded(), we must also add a C function with that name)
Comment 3 GitLab Migration User 2018-08-07 09:31:36 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/accountsservice/accountsservice/issues/24.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.