Bug 61293 - r600g regression: single-filter postprocess broken in 9.0.3
r600g regression: single-filter postprocess broken in 9.0.3
Status: RESOLVED INVALID
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600
9.0
x86-64 (AMD64) Linux (All)
: medium minor
Assigned To: Lauri Kasanen
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-22 17:01 UTC by Lauri Kasanen
Modified: 2013-02-22 21:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lauri Kasanen 2013-02-22 17:01:08 UTC
I just updated to stable 9.0.3, and both MLAA modes are broken in r600g. This is a regression, since they both work in 8.0.3.

llvmpipe in 9.0.3 still works, with both modes, so it's not the changes to PP, but something in r600g.

I'm using the default shader compiler (no R600_LLVM), on a RV710 / HD4350.


I've no time to bisect for the near future, so just marking it up so it doesn't get forgotten.
Comment 1 Lauri Kasanen 2013-02-22 17:01:27 UTC
Assigning to myself.
Comment 2 Lauri Kasanen 2013-02-22 17:03:52 UTC
Oh, seems all PP filters are not working in 9.0.3 r600g, not even nored/nogreen/noblue.
Comment 3 Lauri Kasanen 2013-02-22 17:08:16 UTC
Checking futher, it's only the single-filter case on r600g that's broken. When running more than one filter on r600g, their combined effect works as intended.

Using only a single filter, nothing happens.
Comment 4 Lauri Kasanen 2013-02-22 21:06:58 UTC
This is fixed in both master and the 9.1 branch, and backporting the two commits (eae9674f18 and 3e163a137be7f) is not trivial and would risk creating bugs.

So closing the bug.