Bug 61446 - [r600-llvm + mesa] on Evergreen & compiz 0.8: exposé-like feature & zoom lead to black screen
Summary: [r600-llvm + mesa] on Evergreen & compiz 0.8: exposé-like feature & zoom lead...
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-25 14:33 UTC by jackdachef
Modified: 2013-03-06 14:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log; error message probably was there right from the start / during launch (66.20 KB, text/plain)
2013-02-25 14:33 UTC, jackdachef
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jackdachef 2013-02-25 14:33:00 UTC
Created attachment 75509 [details]
Xorg.0.log; error message probably was there right from the start / during launch

- xf86-video-ati ddx git
- drm git
- mesa git

~ amd64, Gentoo with 3.7.9 kernel


I'm running compiz 0.8* (0.9* is unstable for me and it's also not as fast & stable as 0.8* - at least for me)


- the exposé-like feature leads to a black screen

- likewise with the zoom feature

- and switching between virtual desktops (4 virtual desktops)


Behavior & animation for Expose Plugin is:

- Expo animation: Vortex
- Reflection [x]


when Reflection is activated (in ccsm) little parts of the animation can be seen on a almost entirely black screen - after the animation has finished the screen is/stays black



zoom: 
as soon as the screen is zoomed in a little it's black


switching between virtual desktops (via alt + left/right/up/down key button):
as long as compiz is showing the animation the screen is black at the beginning and end the desktop is viewable




some information:

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cypress PRO [Radeon HD 5800 Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cypress HDMI Audio [Radeon HD 5800 Series]

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cypress PRO [Radeon HD 5800 Series] (prog-if 00 [VGA controller])
Subsystem: Advanced Micro Devices [AMD] nee ATI Device 0b00
Flags: bus master, fast devsel, latency 0, IRQ 49
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at fbde0000 (64-bit, non-prefetchable) [size=128K]
I/O ports at c000 [size=256]
Expansion ROM at fbdc0000 [disabled] [size=128K]
Capabilities: [50] Power Management version 3
Capabilities: [58] Express Legacy Endpoint, MSI 00
Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
Capabilities: [150] Advanced Error Reporting
Kernel driver in use: radeon

01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cypress HDMI Audio [Radeon HD 5800 Series]
Subsystem: Advanced Micro Devices [AMD] nee ATI Cypress HDMI Audio [Radeon HD 5800 Series]
Flags: bus master, fast devsel, latency 0, IRQ 48
Memory at fbdbc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 3
Capabilities: [58] Express Legacy Endpoint, MSI 00
Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
Capabilities: [150] Advanced Error Reporting
Kernel driver in use: snd_hda_intel


[ 63.900] (--) RADEON(0): Chipset: "ATI Radeon HD 5800 Series" (ChipID = 0x6899)




[   60.674679] [drm] Initialized drm 1.1.0 20060810
[   60.756401] [drm] radeon kernel modesetting enabled.
[   60.756537] [drm] initializing kernel modesetting (CYPRESS 0x1002:0x6899 0x1002:0x0B00).
[   60.756643] [drm] register mmio base: 0xFBDE0000
[   60.756645] [drm] register mmio size: 131072
[   60.756723] ATOM BIOS: CYPRESS
[   60.756747] radeon 0000:01:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[   60.756750] radeon 0000:01:00.0: GTT: 512M 0x0000000040000000 - 0x000000005FFFFFFF
[   60.760745] [drm] Detected VRAM RAM=1024M, BAR=256M
[   60.760750] [drm] RAM width 256bits DDR
[   60.760785] [TTM] Zone  kernel: Available graphics memory: 4078130 kiB
[   60.760786] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[   60.760788] [TTM] Initializing pool allocator
[   60.760791] [TTM] Initializing DMA pool allocator
[   60.760809] [drm] radeon: 1024M of VRAM memory ready
[   60.760810] [drm] radeon: 512M of GTT memory ready.
[   60.760824] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[   60.760825] [drm] Driver supports precise vblank timestamp query.
[   60.760861] radeon 0000:01:00.0: irq 49 for MSI/MSI-X
[   60.760869] radeon 0000:01:00.0: radeon: using MSI.
[   60.760893] [drm] radeon: irq initialized.
[   60.760897] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   60.762106] [drm] probing gen 2 caps for device 8086:d138 = 2/0
[   60.762112] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[   60.762179] [drm] Loading CYPRESS Microcode
[   60.815299] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
[   60.815430] radeon 0000:01:00.0: WB enabled
[   60.815433] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xffff88023405dc00
[   60.832111] [drm] ring test on 0 succeeded in 1 usecs
[   60.832300] [drm] ib test on ring 0 succeeded in 0 usecs
[   60.832750] [drm] Radeon Display Connectors
[   60.832753] [drm] Connector 0:
[   60.832755] [drm]   DP-1
[   60.832756] [drm]   HPD4
[   60.832759] [drm]   DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
[   60.832760] [drm]   Encoders:
[   60.832762] [drm]     DFP1: INTERNAL_UNIPHY2
[   60.832764] [drm] Connector 1:
[   60.832766] [drm]   HDMI-A-1
[   60.832767] [drm]   HPD5
[   60.832769] [drm]   DDC: 0x6460 0x6460 0x6464 0x6464 0x6468 0x6468 0x646c 0x646c
[   60.832771] [drm]   Encoders:
[   60.832772] [drm]     DFP2: INTERNAL_UNIPHY2
[   60.832774] [drm] Connector 2:
[   60.832776] [drm]   DVI-I-1
[   60.832777] [drm]   HPD1
[   60.832779] [drm]   DDC: 0x6450 0x6450 0x6454 0x6454 0x6458 0x6458 0x645c 0x645c
[   60.832781] [drm]   Encoders:
[   60.832783] [drm]     DFP3: INTERNAL_UNIPHY1
[   60.832785] [drm]     CRT2: INTERNAL_KLDSCP_DAC2
[   60.832786] [drm] Connector 3:
[   60.832788] [drm]   DVI-I-2
[   60.832790] [drm]   HPD6
[   60.832792] [drm]   DDC: 0x6470 0x6470 0x6474 0x6474 0x6478 0x6478 0x647c 0x647c
[   60.832793] [drm]   Encoders:
[   60.832795] [drm]     DFP4: INTERNAL_UNIPHY
[   60.832797] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[   60.832845] [drm] Internal thermal controller with fan control
[   60.832877] [drm] radeon: power management initialized
[   60.919422] [drm] fb mappable at 0xD0142000
[   60.919424] [drm] vram apper at 0xD0000000
[   60.919425] [drm] size 8294400
[   60.919426] [drm] fb depth is 24
[   60.919427] [drm]    pitch is 7680
[   60.919457] fbcon: radeondrmfb (fb0) is primary device
[   61.143231] Console: switching to colour frame buffer device 240x67
[   61.147043] fb0: radeondrmfb frame buffer device
[   61.147044] drm: registered panic notifier
[   61.147048] [drm] Initialized radeon 2.24.0 20080528 for 0000:01:00.0 on minor 0
Comment 1 jackdachef 2013-02-25 14:33:47 UTC
the llvm-version I'm using is from following overlay:

http://cgit.freedesktop.org/~tstellar/llvm/
Comment 2 Michel Dänzer 2013-03-06 14:25:28 UTC
Does it work better if you switch Mesa to the 9.1 branch or LLVM to the main trunk?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.