Bug 6161 - Lockup of X server in NVSync
Lockup of X server in NVSync
Status: RESOLVED DUPLICATE of bug 3168
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open)
6.8.2
x86 (IA32) Linux (All)
: highest blocker
Assigned To: Xorg Project Team
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 00:51 UTC by Benjamin Monate
Modified: 2008-05-19 19:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Monate 2006-03-07 00:51:05 UTC
While moving a scrollbar in a Motif application, I can deterministically lock
the Xserver.
Debugging with symbols shows this backtrace :

#0  0x080ef0d8 in NVSync (pScrn=0x8be62e8) at nv_xaa.c:301
#1  0x083c776a in XAAPaintWindow (pWin=0x8d6b868, prgn=0x8dca448, what=0) at
xaaPaintWin.c:183
#2  0x086b9cc4 in damagePaintWindow (pWindow=0x8d6b868, prgn=0x8dca448, what=0)
at damage.c:1560
#3  0x086906f2 in miWindowExposures (pWin=0x8d6b868, prgn=0x8dca448,
other_exposed=0x0) at miexpose.c:564
#4  0x084f1dcc in xf86XVWindowExposures (pWin=0x8d6b868, reg1=0x8dca448,
reg2=0x0) at xf86xv.c:1061
#5  0x08686c50 in miHandleValidateExposures (pWin=0x8c22158) at miwindow.c:468
#6  0x08686f79 in miMoveWindow (pWin=0x8dd8048, x=133, y=563,
pNextSib=0x8dad468, kind=VTMove)
    at miwindow.c:556
#7  0x0856232f in ConfigureWindow (pWin=0x8dd8048, mask=3, vlist=0x8d1df6c,
client=0x8d200c0)
    at window.c:2476
#8  0x0853553a in ProcConfigureWindow (client=0x8d200c0) at dispatch.c:771
#9  0x08534a98 in Dispatch () at dispatch.c:455
#10 0x0854d7b1 in main (argc=4, argv=0xbfa9dd44, envp=0xbfa9dd58) at main.c:476

The hardware is : 

0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX
420] (rev a3) (prog-if 00 [VGA])
        Subsystem: nVidia Corporation: Unknown device 015a
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 11
        Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f4000000 (32-bit, prefetchable) [size=64M]
        Memory at f3f80000 (32-bit, prefetchable) [size=512K]
        Expansion ROM at 80000000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0

What other informations do you need to understand the problem ?

Thanks for your help
B.M
Comment 1 Benjamin Herrenschmidt 2006-03-07 08:49:13 UTC
Can you try with 6.9 or 7.0 ?
Comment 2 Benjamin Monate 2006-03-08 21:50:15 UTC
Same symptoms with xorg 7.0.
If you can provide a static binary with symbols, I can try it and check where it
is locked in 7.0.
Comment 3 Benjamin Herrenschmidt 2006-03-09 08:23:57 UTC
Why would you need a static binary ?
Comment 4 Benjamin Monate 2006-03-09 19:57:19 UTC
I just need a binary with debbuging symbols that would run on my Ubuntu 5.10
distro without breaking my existing installation.
Comment 5 Daniel Stone 2007-02-27 01:30:47 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 6 Benjamin Close 2008-05-19 19:32:47 UTC
This is a common bug, not specific to linux/an arch. Marking as duplicate as the other bug report has more info

*** This bug has been marked as a duplicate of bug 3168 ***