Bug 61779 - avcenc tool failed to test HRD
Summary: avcenc tool failed to test HRD
Status: CLOSED FIXED
Alias: None
Product: libva
Classification: Unclassified
Component: intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: haihao
QA Contact: Sean V Kelley
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-04 07:56 UTC by Du Yan
Modified: 2014-05-22 02:31 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Buffer analysis for 1080P IP mode (160.15 KB, text/plain)
2014-05-22 02:24 UTC, Focus.Luo
Details
Buffer analysis for D1 resoluation(IP mode) (165.80 KB, text/plain)
2014-05-22 02:25 UTC, Focus.Luo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Du Yan 2013-03-04 07:56:51 UTC
Bug Info
------------------------
HRD failed because parameter failed to passed by the avcenc tool for the HRD testing, it is caused by avcenc tools not HRD algorithm/setting in driver.


Reproduce steps:
----------------
1.   xinit &
2.   avcenc 1920 1080 /home/encoder/encoderbitstreams.bak/1080p_blue_sky.yuv
/tmp/1.264 fb=20000 mode=1
3.   Analysis the 1.264 file with Elecard Buffer Analyzer, then HRD test
passed.
4.   avcenc 704 576
/home/encoder/encoderbitstreams.bak/CITY_704x576_30_orig_01.yuv /tmp/2.264
fb=20000 mode=1
5.   Analysis the 2.264 file with Elecard Buffer Analyzer, overflow error
showed.
Comment 1 Focus.Luo 2014-05-22 02:24:50 UTC
Created attachment 99550 [details]
Buffer analysis for 1080P IP mode
Comment 2 Focus.Luo 2014-05-22 02:25:53 UTC
Created attachment 99551 [details]
Buffer analysis for D1 resoluation(IP mode)
Comment 3 Focus.Luo 2014-05-22 02:30:37 UTC
Before used Yakui's latest patch(ww21.2) for libva, found the buffer over flow issue by using Vega for HRD buffer analysis for D1 resolution. (See more from the attached files) 
After the patch, the issue gone. So close the bug.
Comment 4 Focus.Luo 2014-05-22 02:31:08 UTC
verified and close the issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.