Bug 61821 - src/mesa/drivers/dri/common/xmlpool.h:96:29: fatal error: xmlpool/options.h
src/mesa/drivers/dri/common/xmlpool.h:96:29: fatal error: xmlpool/options.h
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Other
unspecified
x86-64 (AMD64) Linux (All)
: medium blocker
Assigned To: Matt Turner
http://lists.freedesktop.org/archives...
: patch, regression
: 59261 61984 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-04 23:54 UTC by Vinson Lee
Modified: 2013-06-06 07:10 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
configure.ac: Build dricommon for gallium swrast (1.03 KB, patch)
2013-03-18 19:50 UTC, Mike Stroyan
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2013-03-04 23:54:36 UTC
mesa: e21460b4d515a7ea41e2694c89b5d94b0bd84d54

$ ./autogen.sh --with-dri-drivers= --with-gallium-drivers=swrast
[...]
$ make
[...]
Making all in drm
make[5]: Entering directory `src/gallium/state_trackers/dri/drm'
  CC     dri_screen.lo
In file included from dri_screen.c:33:0:
src/mesa/drivers/dri/common/xmlpool.h:96:29: fatal error: xmlpool/options.h: No such file or directory
compilation terminated.

998d975e38db7478781130b42a4fb68d6b181055 is the first bad commit
commit 998d975e38db7478781130b42a4fb68d6b181055
Author: Daniel Martin <consume.noise@gmail.com>
Date:   Thu Feb 28 19:39:06 2013 +0100

    Fix build of swrast only without libdrm

    Reviewed-by: Matt Turner <mattst88@gmail.com>
    Signed-off-by: Daniel Martin <consume.noise@gmail.com>

:100644 100644 5f95a78d26f241557754adaeffe73d3e3d3a88bb 785259554bbb833bc6d03c50414b8262bc553341 M    $
bisect run success
Comment 1 Carl Worth 2013-03-05 23:52:00 UTC
*** Bug 59261 has been marked as a duplicate of this bug. ***
Comment 2 Vinson Lee 2013-03-07 23:37:32 UTC
*** Bug 61984 has been marked as a duplicate of this bug. ***
Comment 3 LoneVVolf 2013-03-08 18:58:01 UTC
same bug with this configure command :

  ./autogen.sh --prefix=/usr \
    --sysconfdir=/etc \
    --with-dri-driverdir=/usr/lib/xorg/modules/dri \
    --with-gallium-drivers=r300,r600,radeonsi,swrast \
    --with-dri-drivers=swrast \
    --enable-gallium-llvm \
    --enable-egl \
    --enable-gallium-egl \
    --with-egl-platforms=x11,drm,wayland \
    --enable-shared-glapi \
    --enable-gbm \
    --enable-glx-tls \
    --enable-dri \
    --enable-glx \
    --enable-osmesa \
    --enable-gles1 \
    --enable-gles2 \
    --enable-texture-float \
    --enable-xa \
    --enable-vdpau \
    --enable-gallium-gbm \
    --enable-xvmc \
    --enable-xorg \
    --enable-r600-llvm-compiler \
    --with-llvm-shared-libs
Comment 4 Matt Turner 2013-03-09 05:25:54 UTC
Committed as 07f2dee7319b084e00288d74b29b07b62d888948.
Comment 5 Vinson Lee 2013-03-13 06:25:20 UTC
mesa: a6bb7a94957468453c436e3860ee2dd47575c461 (master)

This is still failing for me here. Failure case and output is still identical to comment #0.
Comment 6 Marc Dietrich 2013-03-13 08:57:08 UTC
works fine here.

git clean -f -d -x -e b.sh
./autogen.sh                    \
        --prefix=/usr           \
        --libdir=/usr/lib64     \
        --disable-debug         \
        --enable-texture-float  \
        --enable-gles1          \
        --enable-gles2          \
        --enable-openvg         \
        --enable-xorg           \
        --enable-xvmc           \
        --enable-vdpau          \
        --enable-shared-glapi   \
        --enable-glx-tls        \
        --enable-gallium-llvm   \
        --enable-gallium-egl    \
        --enable-gbm            \
        --enable-gallium-gbm    \
        --with-gallium-drivers=swrast,r600 \
        --with-llvm-prefix=/source/dri-project/llvm/Release \
        --with-llvm-shared-libs \
        --enable-r600-llvm-compiler \
        --with-dri-drivers="" \
        --with-dri-driverdir=/usr/lib64/dri
make
Comment 7 Mike Stroyan 2013-03-18 19:50:48 UTC
Created attachment 76708 [details] [review]
configure.ac: Build dricommon for gallium swrast

The 07f2dee7 commit added setting HAVE_COMMON_DRI in gallium_check_st().
But the dri-swrast case didn't use gallium_check_st().
I can get dri/common built when needed by using gallium_check_st
instead of directly setting GALLIUM_TARGET_DIRS to add "dri-swrast".
Comment 8 Andreas Boll 2013-06-06 07:10:17 UTC
Fixed with 962204961def009610e60b23d40a22f064214dc7