Bug 61947 - nullpointer dereference causes xorg-server segfault when nouveau DRI driver is loaded
nullpointer dereference causes xorg-server segfault when nouveau DRI driver i...
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/nouveau
9.1
All Linux (All)
: medium critical
Assigned To: Nouveau Project
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-07 08:51 UTC by Jan de Groot
Modified: 2013-03-07 19:00 UTC (History)
0 users

See Also:


Attachments
Patch that fixes the segfault (522 bytes, text/plain)
2013-03-07 08:51 UTC, Jan de Groot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan de Groot 2013-03-07 08:51:39 UTC
Created attachment 76086 [details]
Patch that fixes the segfault

Chromium can crash Xorg when the nouveau DRI driver is loaded. This is due to a nullpointer dereference.

Archlinux bug (Xorg crash): https://bugs.archlinux.org/task/33994
Fedora bug (Application crash, same cause): https://bugzilla.redhat.com/show_bug.cgi?id=862466

As suggested in the Fedora bug, comment 15, attached is a patch that fixes this issue (confirmed on Archlinux). This is the same check the Intel DRI driver does, so I think it's needed there.
Comment 1 Marcin Slusarz 2013-03-07 19:00:48 UTC
Thanks. I pushed it to master and marked as stable candidate.

http://cgit.freedesktop.org/mesa/mesa/commit/?id=17f1cb1d99e66227d1e05925ef937643f5c1089a