Bug 62202 - Mesa demo dest window of wincopy flickers while toggle f/b buffer on software render
Summary: Mesa demo dest window of wincopy flickers while toggle f/b buffer on software...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/llvmpipe (show other bugs)
Version: git
Hardware: All Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-12 07:24 UTC by kobeqin
Modified: 2019-09-18 18:31 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kobeqin 2013-03-12 07:24:50 UTC
System Environment:       
--------------------------
Libdrm:         (master)libdrm-2.4.42
Mesa:           (9.1)mesa-9.1
Xserver:                (server-1.13-branch)xorg-server-1.13.2.902
Xf86_video_intel:               (master)2.21.3
Cairo:          (master)1.12.14
Libva:          (master)libva-1.1.0
Libva_intel_driver:             (master)00f65b78e6de520a4820702207ce098c6b073724

Bug detailed description:
-----------------------------
Destination window of wincopy flickers while press "f" to toggle f/b color buffer
If run on hardware,type "./wincopy", f/b color buffer rendered normally

Reproduce steps:
----------------------------
1. xinit&
2. gnome-session&
3. LIBGL_ALWAYS_SOFTWARE=1 ./wincopy
Comment 1 Tapani Pälli 2014-07-24 06:40:52 UTC
updating status, nowadays swrast driver crashes with this demo

--- 8< ----
Drawing to GL_FRONT buffer

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff6d70483 in blit_copy_pixels (ctx=0x7ffff7fd7010, srcx=0, srcy=0, width=300, height=300, dstx=0, dsty=0, type=6144)
    at state_tracker/st_cb_drawpixels.c:1414
warning: Source file is more recent than executable.
1414	         drawY = rbDraw->Base.Height - drawY - drawH;
Missing separate debuginfos, use: debuginfo-install expat-2.1.0-5.fc19.x86_64 libGLEW-1.9.0-3.fc19.x86_64 libXau-1.0.8-1.fc19.x86_64 libXdamage-1.1.4-3.fc19.x86_64 libXext-1.3.2-1.fc19.x86_64 libXfixes-5.0.1-1.fc19.x86_64 libXxf86vm-1.1.3-1.fc19.x86_64 libffi-3.0.13-4.fc19.x86_64 libgcc-4.8.3-1.fc19.x86_64 libstdc++-4.8.3-1.fc19.x86_64 libxcb-1.9-3.fc19.x86_64 llvm-libs-3.3-4.fc19.x86_64 mesa-libGLU-9.0.0-4.fc19.x86_64 zlib-1.2.7-10.fc19.x86_64
(gdb) bt
#0  0x00007ffff6d70483 in blit_copy_pixels (ctx=0x7ffff7fd7010, srcx=0, srcy=0, width=300, height=300, dstx=0, dsty=0, 
    type=6144) at state_tracker/st_cb_drawpixels.c:1414
#1  0x00007ffff6d708bb in st_CopyPixels (ctx=0x7ffff7fd7010, srcx=0, srcy=0, width=300, height=300, dstx=0, dsty=0, type=6144)
    at state_tracker/st_cb_drawpixels.c:1500
#2  0x00007ffff6c11b4c in _mesa_CopyPixels (srcx=0, srcy=0, width=300, height=300, type=6144) at main/drawpix.c:269
#3  0x0000000000401814 in Redraw () at wincopy.c:164
#4  0x0000000000401905 in EventLoop () at wincopy.c:232
#5  0x00000000004013cf in main (argc=<optimized out>, argv=<optimized out>) at wincopy.c:312
Comment 2 Tapani Pälli 2014-07-24 07:51:53 UTC
> warning: Source file is more recent than executable.

Sorry about this, it came from unrelated changes .. however I just tested that the function names match fine with a clean tree. Had also a bit more look at it, these issues happen because rbDraw is NULL, maybe st_DrawBuffers would be a good place to start looking what goes wrong (?)
Comment 3 GitLab Migration User 2019-09-18 18:31:16 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/226.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.