Bug 62650 - systemd-coredump maintains the dump in memory
Summary: systemd-coredump maintains the dump in memory
Status: RESOLVED FIXED
Alias: None
Product: systemd
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: systemd-bugs
QA Contact: systemd-bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-22 17:51 UTC by Paresh Verma
Modified: 2014-06-21 02:19 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paresh Verma 2013-03-22 17:51:15 UTC
Hi,
Often I have found multiple systemd-coredump running, occupying huge memory. I presume that systemd-coredump is meant for handling the dumps of crashed processes, but why does it need to keep them persistently in memory. They have to be manually killed (I allowed them to stay in memory for quite some time to be sure of this).

Other users are also facing the same issue as mentioned in https://bbs.archlinux.org/viewtopic.php?pid=1247900

For now I have disabled the coredump. If required I could post the steps to reproduce the error (however I feel crashing a process should be sufficient)

Please clarify if this is a config issue or is something wrong at our end.
Comment 1 Paresh Verma 2013-05-18 09:23:37 UTC
Should I expect some response?
Comment 2 Wiebe Cazemier 2013-11-10 18:19:38 UTC
I'm having this issue as well. My computer starts swapping heavily when this happens, often necessitating a hard reboot.

It's not with Chromium for me though, as described in that Archlinux discussion. It seems to be wine+µTorrent for me. µTorrent has a tendency to crash here, so I guess it just triggers the coredump.
Comment 3 Hussam Al-Tayeb 2014-06-20 23:48:27 UTC
All systemd-coredump instances exit correctly on their own when the dumps have been written to journal.

Not really a bug?
Comment 4 Zbigniew Jedrzejewski-Szmek 2014-06-21 02:19:59 UTC
(In reply to comment #1)
> Should I expect some response?
When someone gets around to handling a bug, or they need some info, or have any useful input at all, then yes. Otherwise, no.

(In reply to comment #3)
> All systemd-coredump instances exit correctly on their own when the dumps
> have been written to journal.
> 
> Not really a bug?
It's not a bug, things were working as designed. The problem was that writing big entries to the journal was a bit slow.

As of http://cgit.freedesktop.org/systemd/systemd/commit/?id=34c10968, coredumps are written to a file on disk. This should be both faster and require less memory.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.