Bug 62663 - Resizing wayland clients causes them to close unexpectedly
Summary: Resizing wayland clients causes them to close unexpectedly
Status: RESOLVED DUPLICATE of bug 63404
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: high major
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-23 11:06 UTC by Scott Moreau
Modified: 2013-04-23 14:04 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
full backtrace of the bug (7.89 KB, text/plain)
2013-03-23 17:22 UTC, Rafal Mielniczuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Moreau 2013-03-23 11:06:08 UTC
With latest commits to mesa, resizing a surface in weston causes the surface to disappear. gdb shows the process exited normally. Sometimes though, I am able to crash weston which leaves the single message "intel_do_flush_locked failed: Invalid argument". I bisected to find:

de315f76a266ce51ca0638b9ea2ec3ccfd31f03b is the first bad commit
commit de315f76a266ce51ca0638b9ea2ec3ccfd31f03b
Author: Kristian Høgsberg <krh@bitplanet.net>
Date:   Sat Feb 2 12:26:12 2013 -0500

    wayland: Add prime fd passing as a buffer sharing mechanism
    
    Reviewed-by: Ander Conselvan de Oliveira <conselvan2@gmail.com>

:040000 040000 64fd9e653501abd636b0aebcb7b6f3d046cfad88 8944e7c531c68cc90173b16bc787a457a47ef66b M	src


The bug can be reproduced with:

wayland:
7165bf21917ed1c4f5ec823a1e1642a9e83aa984
mesa:
b101a094b5576337f5bb7aecf525eb1755757b9c
weston:
0f3f97d34a708976f561f4f5d5eac69c0e5483e2


Sandybridge, xubuntu 12.10 64bit, 3.5.0-26-generic
Comment 1 min2 2013-03-23 12:20:25 UTC
I cannot reproduce this issue on:

 wayland 7165bf21917ed1c4f5ec823a1e1642a9e83aa984
 weston 706d15e2a7048875f6ebbda529f53cf4a090b935
 mesa b101a094b5576337f5bb7aecf525eb1755757b9c



please, consider rebuilding the whole stack.
Comment 2 Scott Moreau 2013-03-23 14:46:18 UTC
(In reply to comment #1)
> I cannot reproduce this issue on:
> 
>  wayland 7165bf21917ed1c4f5ec823a1e1642a9e83aa984
>  weston 706d15e2a7048875f6ebbda529f53cf4a090b935
>  mesa b101a094b5576337f5bb7aecf525eb1755757b9c
> 
> 
> 
> please, consider rebuilding the whole stack.

Hi, this only happens with Intel. What hardware are you using to test there?
Comment 3 Rafal Mielniczuk 2013-03-23 16:41:27 UTC
I can reproduce it on Intel Ivy Bridge

wayland: 7165bf21917ed1c4f5ec823a1e1642a9e83aa984
mesa:    3e10ab6b22341c06a9352b1e029b923f4d8405b9
weston:  0f3f97d34a708976f561f4f5d5eac69c0e5483e2

Sometimes wayland client dies, sometimes weston exits with output:
intel_do_flush_locked failed: No such file or directory

Intel Ivy Bridge
Linux 3.7.10-1-ARCH x86_64
Comment 4 Travis Mosley 2013-03-23 16:59:21 UTC
I can reproduce it when the only change in software is going from mesa 9.1.1 to mesa git.

Mesa revision: 3e10ab6b22341c06a9352b1e029b923f4d8405b9
Comment 5 Travis Mosley 2013-03-23 17:02:03 UTC
My hardware seems to be Sandybridge, but I can't tell with this lspci:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Linux 3.8.1
Arch Linux
Comment 6 Rafal Mielniczuk 2013-03-23 17:22:00 UTC
Created attachment 76944 [details]
full backtrace of the bug
Comment 7 Ander Conselvan de Oliveira 2013-04-23 14:04:24 UTC
This is actually a kernel bug, introduced in kernel 3.8. It seems some distros picked up the patch that introduced the issues, hence the failures on Ubuntu with 3.5 and ARCH with 3.7. They should include also a fix for this issue. Details on the duplicate bug.

*** This bug has been marked as a duplicate of bug 63404 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.