Bug 62916 - NVEnterVT fails with hybrid cards
NVEnterVT fails with hybrid cards
Status: RESOLVED DUPLICATE of bug 59190
Product: xorg
Classification: Unclassified
Component: Driver/nouveau
unspecified
x86-64 (AMD64) Linux (All)
: medium critical
Assigned To: Maarten Lankhorst
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-29 21:23 UTC by zeng.shixin
Modified: 2013-05-01 05:02 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
[PATCH] hw/xfree86: Allow xf86SetDesiredModes to succeed if no crtc's are enabled. (863 bytes, patch)
2013-04-29 09:33 UTC, Maarten Lankhorst
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description zeng.shixin 2013-03-29 21:23:43 UTC
Since on system with hybrid cards, the nvidia card might not be connecting to the screen, so Xf86SetDisiredMode could fail, which results in a fatal error for Xserver:
[ 91825.257] (II) NOUVEAU(G0): NVEnterVT is called.
[ 91825.258] 
Fatal server error:
[ 91825.258] EnterVT failed for gpu screen 0


The following dirty hack fixes the problem. We should check for the connected screen before setting mode, but I don't know how to do that, since this is my first time to look at nouveau code.

--- nv_driver-orig.c	2013-03-29 17:19:34.876953461 -0400
+++ nv_driver.c	2013-03-29 17:20:15.810287942 -0400
@@ -407,8 +407,7 @@
 	if (ret)
 		ErrorF("Unable to get master: %s\n", strerror(errno));
 
-	if (!xf86SetDesiredModes(pScrn))
-		return FALSE;
+	xf86SetDesiredModes(pScrn);
 
 	if (pNv->overlayAdaptor && pNv->Architecture != NV_ARCH_04)
 		NV10WriteOverlayParameters(pScrn);
Comment 1 Maarten Lankhorst 2013-04-29 09:33:31 UTC
Created attachment 78590 [details] [review]
[PATCH] hw/xfree86: Allow xf86SetDesiredModes to succeed if no crtc's are enabled.

I just noticed the same problem with xserver 1.14, x1.13 worked fine. Hopefully attached patch fixes it for you too.
Comment 2 Maarten Lankhorst 2013-04-29 09:45:13 UTC

*** This bug has been marked as a duplicate of bug 59190 ***